Bug 992932 - SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from 'create' accesses on the unix_dgram_socket .
SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from 'create' accesse...
Status: CLOSED DUPLICATE of bug 992920
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:49827e6d6528c428db6e61ec654...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 04:56 EDT by Samium Gromoff
Modified: 2013-08-05 10:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 10:22:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samium Gromoff 2013-08-05 04:56:33 EDT
Description of problem:
I am trying to run ejabberd with PAM authentication, but SELinux shoots that down.

I have the following in my /etc/ejabberd/ejabberd.conf:
---- >8 ----
{auth_method, pam}.
{pam_service, "login"}.
---- 8< ----
SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from 'create' accesses on the unix_dgram_socket .

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that epam should be allowed create access on the  unix_dgram_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep epam /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:system_r:rabbitmq_beam_t:s0
Target Objects                 [ unix_dgram_socket ]
Source                        epam
Source Path                   /usr/lib64/ejabberd/priv/bin/epam
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ejabberd-2.1.13-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-301.fc19.x86_64 #1 SMP Tue
                              Jun 11 19:39:38 UTC 2013 x86_64 x86_64
Alert Count                   16
First Seen                    2013-08-02 17:55:42 MSK
Last Seen                     2013-08-05 11:59:25 MSK
Local ID                      da08c608-569c-43f6-94c2-208e89449d3d

Raw Audit Messages
type=AVC msg=audit(1375689565.281:1593): avc:  denied  { create } for  pid=28188 comm="epam" scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:system_r:rabbitmq_beam_t:s0 tclass=unix_dgram_socket


type=SYSCALL msg=audit(1375689565.281:1593): arch=x86_64 syscall=socket success=no exit=EACCES a0=1 a1=80002 a2=0 a3=26 items=0 ppid=28154 pid=28188 auid=4294967295 uid=991 gid=989 euid=0 suid=0 fsuid=0 egid=989 sgid=989 fsgid=989 ses=4294967295 tty=(none) comm=epam exe=/usr/lib64/ejabberd/priv/bin/epam subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: epam,rabbitmq_beam_t,rabbitmq_beam_t,unix_dgram_socket,create

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.9.5-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-05 10:22:59 EDT

*** This bug has been marked as a duplicate of bug 992920 ***

Note You need to log in before you can comment on or make changes to this bug.