This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 992953 - SELinux is preventing /usr/sbin/unix_chkpwd from 'read' accesses on the file /etc/shadow.
SELinux is preventing /usr/sbin/unix_chkpwd from 'read' accesses on the file ...
Status: CLOSED DUPLICATE of bug 992920
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f77be5de886721b6c2306460062...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 05:29 EDT by Samium Gromoff
Modified: 2013-08-05 10:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 10:38:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samium Gromoff 2013-08-05 05:29:27 EDT
Description of problem:
I am trying to run ejabberd with PAM authentication, but SELinux shoots down PAM-related machinery
during client authentication.

I have the following in my /etc/ejabberd/ejabberd.conf:
---- >8 ----
{auth_method, pam}.
{pam_service, "login"}.
---- 8< ----
SELinux is preventing /usr/sbin/unix_chkpwd from 'read' accesses on the file /etc/shadow.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that unix_chkpwd should be allowed read access on the shadow file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep unix_chkpwd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:shadow_t:s0
Target Objects                /etc/shadow [ file ]
Source                        unix_chkpwd
Source Path                   /usr/sbin/unix_chkpwd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           pam-1.1.6-12.fc19.x86_64
Target RPM Packages           setup-2.8.71-1.fc19.noarch
Policy RPM                    selinux-policy-3.12.1-69.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-301.fc19.x86_64 #1 SMP Tue
                              Jun 11 19:39:38 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-08-05 13:28:14 MSK
Last Seen                     2013-08-05 13:28:14 MSK
Local ID                      1c1f1163-2f24-4c22-8798-c05c0d7faa70

Raw Audit Messages
type=AVC msg=audit(1375694894.607:2114): avc:  denied  { read } for  pid=16674 comm="unix_chkpwd" name="shadow" dev="dm-3" ino=395927 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:shadow_t:s0 tclass=file


type=SYSCALL msg=audit(1375694894.607:2114): arch=x86_64 syscall=open success=no exit=EACCES a0=7f76d525c43b a1=80000 a2=1b6 a3=0 items=0 ppid=16249 pid=16674 auid=4294967295 uid=0 gid=989 euid=0 suid=0 fsuid=0 egid=989 sgid=989 fsgid=989 ses=4294967295 tty=(none) comm=unix_chkpwd exe=/usr/sbin/unix_chkpwd subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: unix_chkpwd,rabbitmq_beam_t,shadow_t,file,read

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.9.5-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-05 10:38:54 EDT

*** This bug has been marked as a duplicate of bug 992920 ***

Note You need to log in before you can comment on or make changes to this bug.