Bug 992964 - Designer allows variables with whitespaces but cannot handle them
Designer allows variables with whitespaces but cannot handle them
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Tihomir Surdilovic
Sona Mala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 05:55 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:13:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error when openning the process definition in the full Designer (13.43 KB, text/plain)
2013-08-05 05:55 EDT, Zuzana Krejčová
no flags Details
error when openning the process or instance model (13.68 KB, text/plain)
2013-08-05 05:56 EDT, Zuzana Krejčová
no flags Details
log after the process is saved (2.20 KB, text/plain)
2013-08-05 05:57 EDT, Zuzana Krejčová
no flags Details
log after the project is built (2.87 KB, text/plain)
2013-08-05 05:58 EDT, Zuzana Krejčová
no flags Details
process used for this issue (4.41 KB, application/xml)
2013-08-05 05:59 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-08-05 05:55:27 EDT
Created attachment 782733 [details]
error when openning the process definition in the full Designer

Description of problem:
Designer allows users to add a variable with a whitespace in its name to the process definition. Validation doesn't show this as a problem, process can be saved and project can be built. It shows up in the Deployments and in the Process Definitions, the process can be started, value is assigned to the variable.

The problem arises when user tries to open any kind of model - deployed process or instance or the process definition in the full Designer in the Authoring section. Designer never finishes loading and server log shows some errors.

The process I used to test this is a simple Start -> End with a process variable called 'some var' of type String.


Version-Release number of selected component (if applicable):
kie-wb 6.0 CR1
Comment 1 Zuzana Krejčová 2013-08-05 05:56:20 EDT
Created attachment 782734 [details]
error when openning the process or instance model
Comment 2 Zuzana Krejčová 2013-08-05 05:57:38 EDT
Created attachment 782735 [details]
log after the process is saved
Comment 3 Zuzana Krejčová 2013-08-05 05:58:03 EDT
Created attachment 782736 [details]
log after the project is built
Comment 4 Zuzana Krejčová 2013-08-05 05:59:03 EDT
Created attachment 782737 [details]
process used for this issue
Comment 5 Zuzana Krejčová 2013-08-05 06:03:03 EDT
As in bug 991374, the process cannot be deleted via GUI since that functionality (for processes) is accessible from the Designer only.
Comment 6 Tihomir Surdilovic 2013-09-23 11:13:00 EDT
process var editor has been changes to no longer accept white spaces. added validation error in case there are some vars that contain spaces.
Comment 10 Zuzana Krejčová 2013-10-16 06:02:12 EDT
It is no longer possible to add a variable with a whitespace.

It is also impossible to import or open a process that contains a variable with whitespace in name. If you try to open such process, there is the already mentioned error and Designer never finishes loading.

I'd consider that alright though, for these reasons:
- you cannot add a variable with whitespace in the Designer - you'd have to change this manually and push the commit through git,
- whitespaces aren't valid characters for id attribute - simplifying a bit, for the name of a variable - only alphanumeric chars, underscores, hyphens and periods should be (as far as I know) and are allowed,
- the main issue is resolved.

The problem with forever loading Designer is already covered by bug 1006734.

Note You need to log in before you can comment on or make changes to this bug.