Bug 993458 - Regression in i915 since 3.9.9-302: flickering display after KMS initialization [NEEDINFO]
Regression in i915 since 3.9.9-302: flickering display after KMS initialization
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 21:40 EDT by Michel Alexandre Salim
Modified: 2014-03-10 10:45 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 10:45:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jforbes: needinfo?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 59841 None None None Never

  None (edit)
Description Michel Alexandre Salim 2013-08-05 21:40:22 EDT
Description of problem:
On my Dell XPS 13" (Core i7 3rd Gen, integrated graphics, 1080p panel), once I upgraded from 3.9.9-302 to 3.10.3-300 the display flickers continuously as soon as KMS is initialized.

The regression is still present in 3.10.4-300 (already noted in Bodhi, but not downvoted since that build doesn't introduce this problem)

Version-Release number of selected component (if applicable):
kernel-3.10.3-300.fc19.x86_64
kernel-3.10.4-300.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot the kernel in question

Actual results:
Garbled screen after KMS initialization (barely readable)

Expected results:
No regression

Additional info:
Comment 1 Michel Alexandre Salim 2013-08-27 08:04:58 EDT
Might be related to bug 986375 and 990565 -- tried the latest 3.10.x (F19) and 3.11.x (F20) kernels from Koji and the problem persists, while the last 3.9.x release works.

Troubling thing is, 990565 is on a system with a Radeon card and this is on Intel
Comment 2 Michel Alexandre Salim 2013-08-27 08:13:08 EDT
Per the Arch forum post: https://bbs.archlinux.org/viewtopic.php?id=167199

this seems to be the bug being worked on in the upstream bug tracker, now linked to this entry
Comment 3 Michel Alexandre Salim 2013-10-02 10:44:51 EDT
Not sure this is a problem with Intel's X driver - per https://aur.archlinux.org/packages/linux-mainline-dellxps/ (mentioned in the Arch forum post) this is definitely an issue with their DRI driver.

Per the suggestion in the comments on that AUR package, disabling Secure Boot and enabling the Legacy Option ROM works as a temporary workaround.

At least it looks like the mainstream bug report has a solution in the works, so hopefully 3.12 will carry the fix (but will it be available for Fedora 19 users?)
Comment 4 Justin M. Forbes 2014-01-03 17:11:59 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 5 Justin M. Forbes 2014-03-10 10:45:17 EDT
*********** MASS BUG UPDATE **************

This bug has been in a needinfo state for more than 1 month and is being closed with insufficient data due to inactivity. If this is still an issue with Fedora 19, please feel free to reopen the bug and provide the additional information requested.

Note You need to log in before you can comment on or make changes to this bug.