Bug 993591 - Two abrt icons in app menu is confusing
Two abrt icons in app menu is confusing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
: 994284 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 04:58 EDT by Kamil Páral
Modified: 2016-11-30 19:44 EST (History)
9 users (show)

See Also:
Fixed In Version: gnome-abrt-0.3.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-14 20:55:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
overview-search (976.29 KB, image/png)
2013-08-06 04:58 EDT, Kamil Páral
no flags Details
overview-all (1.06 MB, image/png)
2013-08-06 04:59 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-08-06 04:58:21 EDT
Created attachment 783244 [details]
overview-search

Description of problem:
See overview-search.png. When I search for "abrt", I see two same icons and I'm not able to tell the difference. The name is cut off and it doesn't allow me to recognize what each icon represents.

If I don't search for "abrt" but see all applications, it's even worse. Abrt preferences are in the top hierarchy, but the real abrt app is hidden inside "Sundry" app group. See overview-all.png.

Please, don't make abrt preferences a separate launcher. Imagine what would happen if every application did the same - the app menu would be swamped with duplicate icons - Firefox and Firefox preferences, Rhythmbox and Rhythmbox preferences, LibreOffice and LibreOffice preferences, ...

It doesn't make sense, right? Just make the preferences window available from the main ABRT GUI app. It doesn't need to have a separate launcher.

Version-Release number of selected component (if applicable):
abrt-2.1.6-2.fc19.x86_64
abrt-addon-ccpp-2.1.6-2.fc19.x86_64
abrt-addon-kerneloops-2.1.6-2.fc19.x86_64
abrt-addon-python-2.1.6-2.fc19.x86_64
abrt-addon-uefioops-2.1.6-2.fc19.x86_64
abrt-addon-vmcore-2.1.6-2.fc19.x86_64
abrt-addon-xorg-2.1.6-2.fc19.x86_64
abrt-dbus-2.1.6-2.fc19.x86_64
abrt-desktop-2.1.6-2.fc19.x86_64
abrt-gui-2.1.6-2.fc19.x86_64
abrt-libs-2.1.6-2.fc19.x86_64
abrt-plugin-bodhi-2.1.6-2.fc19.x86_64
abrt-retrace-client-2.1.6-2.fc19.x86_64
gnome-abrt-0.3.0-3.fc19.x86_64


How reproducible:
always

Steps to Reproduce:
1. type abrt in GNOME 3, or see all apps

Expected results:
preferences can be displayed from inside ABRT app, and don't have a separate launcher
Comment 1 Kamil Páral 2013-08-06 04:59:06 EDT
Created attachment 783245 [details]
overview-all
Comment 2 Jakub Filak 2013-08-07 03:46:41 EDT
*** Bug 994284 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Filak 2013-08-07 04:17:02 EDT
I'm going to add a new application menu item to gnome-abrt. system-config-abrt cannot be merged with a configuration window accessible under "Preferences" application menu item because "Preferences" comes from libreport but system-config-abrt is pure abrt application.
Comment 4 Jakub Filak 2013-08-07 08:16:53 EDT
Patches fixing this bug have been submitted for review:
https://lists.fedorahosted.org/pipermail/crash-catcher/2013-August/005131.html
Comment 5 Michael Catanzaro 2013-08-07 10:35:12 EDT
That seems like a good solution.  Thanks for the quick response!
Comment 6 Jakub Filak 2013-08-13 08:19:33 EDT
Fixed in upstream git:

ABRT
----
commit ed0691c38c290fe6d564e54d5d676a6d9533f4b4
commit abdc93e7b8783153ef281b59b128c8862e0cf274
commit b7210ab923dda19f85c04dadb657a3b54e4a8dc7

gnome-abrt
----------
commit 8c8e448cd21124fa7d0bf9355eba25d99542b5ca
commit 4f170d05b5f6b10eaf9c3af0e89cc1ea31fd62ae
Comment 7 Fedora Update System 2013-09-13 09:10:02 EDT
gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19
Comment 8 Fedora Update System 2013-09-13 22:39:55 EDT
Package gnome-abrt-0.3.1-1.fc19, abrt-2.1.7-1.fc19, libreport-2.1.7-1.fc19, satyr-0.9-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.3.1-1.fc19 abrt-2.1.7-1.fc19 libreport-2.1.7-1.fc19 satyr-0.9-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16707/gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-09-14 20:55:08 EDT
gnome-abrt-0.3.1-1.fc19, abrt-2.1.7-1.fc19, libreport-2.1.7-1.fc19, satyr-0.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.