Bug 993655 - GUI: missing name of active zone
GUI: missing name of active zone
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld (Show other bugs)
7.0
Unspecified Unspecified
low Severity unspecified
: rc
: ---
Assigned To: Thomas Woerner
Tomas Dolezal
:
Depends On:
Blocks: 980210
  Show dependency treegraph
 
Reported: 2013-08-06 07:18 EDT by Petr Sklenar
Modified: 2015-03-05 08:22 EST (History)
3 users (show)

See Also:
Fixed In Version: firewalld-0.3.9-10.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 08:22:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-08-06 07:18:21 EDT
Description of problem:
firewall-config: missing name of active zone

Version-Release number of selected component (if applicable):
firewalld-0.3.4-1.fc19.noarch

How reproducible:
rfe

Steps to Reproduce:
1. change zone of connection to non default, like home:
$ firewall-cmd --get-active-zone
home
  interfaces: enp0s25
$ firewall-cmd --get-default-zone
work


Actual results:
GUI > you are not able to see which zone is current

Expected results:
for ex there is name of active zone in the status bar per interface.

Additional info:
Comment 3 Petr Sklenar 2013-08-06 08:46:46 EDT
Actually this stuff like NM connection ~ zone users don't understand much.
There is settings in the NM applet but its hard to understand why users should look at there.
Comment 4 Jiri Popelka 2013-08-16 10:44:12 EDT
(In reply to Petr Sklenar from comment #0)
> Expected results:
> for ex there is name of active zone in the status bar per interface.

Currently we make name of default zone bold in the list of zones and also show it on the status bar on the bottom. Maybe we could show the active zones on the status bar instead of default zone while still marking the default zone bold in the list.

(In reply to Petr Sklenar from comment #3)
> Actually this stuff like NM connection ~ zone users don't understand much.

I see. It's even not been easy for me to explain it to somebody else in a simple way :-(
Comment 5 Jiri Popelka 2013-09-16 12:25:07 EDT
another request for this is bug #1008118
Comment 6 Thomas Woerner 2013-10-02 09:08:45 EDT
Please have a look at the Interface tab in zones. All interfaces (also bound to connections with NM) are located there. You can now also easily change the zone for this connection in there. It is not opening nm-connection-editor anymore.

If this already fits your needs, please close this bug.
Comment 9 Jiri Popelka 2014-06-17 10:43:08 EDT
(In reply to Jiri Popelka from comment #4)
> Currently we make name of default zone bold in the list of zones and also
> show it on the status bar on the bottom. Maybe we could show the active
> zones on the status bar instead of default zone while still marking the
> default zone bold in the list.

Or vice-versa, i.e. keep showing default zone on bottom status bar and make *active* zones (instead of default zone) bold in the list of zones.
Comment 16 errata-xmlrpc 2015-03-05 08:22:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0520.html

Note You need to log in before you can comment on or make changes to this bug.