Bug 993698 - engine-setup is not storing an answer to the "Do you want to install with memory less than recommended?" question
engine-setup is not storing an answer to the "Do you want to install with mem...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.1
Assigned To: Alex Lourie
sefi litmanovich
integration
:
: 1007242 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 07:42 EDT by Lev Veyde
Modified: 2013-11-25 06:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 06:46:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18669 None None None Never
oVirt gerrit 18895 None None None Never

  None (edit)
Description Lev Veyde 2013-08-06 07:42:18 EDT
Description of problem:
engine-setup --generate-answer doesn't store the answer to the "Do you want to install with memory less than recommended?" question.

Thus running the engine-setup with config-append option with the answer file can't complete in silent mode.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run engine-setup --generate-answer=<file> on a machine with less then 4GB of ram.
2. use the same answer file created in step 1 by another installation on another machine with less then 4GB of ram.
3. The setup will issue a question prompt about the amount of memory and fail.

Actual results:
Setup asks question about the memory.

Expected results:
Setup should not ask this question, as answer to it should be stored in answer file.

Additional info:
I tested the upgrade flow - where engine-setup is used to upgrade between versions.
Comment 1 Alon Bar-Lev 2013-09-05 02:12:12 EDT
over automation
Comment 2 Alon Bar-Lev 2013-09-12 09:08:22 EDT
*** Bug 1007242 has been marked as a duplicate of this bug. ***
Comment 3 Sandro Bonazzola 2013-10-21 09:19:42 EDT
Included in 3.3.1 beta.
Comment 4 sefi litmanovich 2013-10-30 12:21:36 EDT
Verified on rhevm 3.3 is20
Comment 5 Sandro Bonazzola 2013-11-25 06:46:21 EST
oVirt 3.3.1 has been released

Note You need to log in before you can comment on or make changes to this bug.