Bug 1007242 - RFE: Teach engine-setup not to ask me already once answered questions during upgrade
RFE: Teach engine-setup not to ask me already once answered questions during ...
Status: CLOSED DUPLICATE of bug 993698
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Alon Bar-Lev
Pavel Stehlik
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 03:59 EDT by Jiri Belka
Modified: 2013-09-12 09:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 09:08:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2013-09-12 03:59:57 EDT
Description of problem:
Teach engine-setup not to ask me already once answered questions during upgrade. Current is completely annoying and primitive.

Version-Release number of selected component (if applicable):
is14

How reproducible:
100%

Steps to Reproduce:
1. install clean rhevm
2. engine-setup
3. upgrade to newer rhevm
4. engine-setup (to do the upgrade itself)

Actual results:
primitive, asking always the same questions

Expected results:
smart, if i onced answered particular question, remember it

Additional info:
be in 21st century. if there would be new question then compare with some file having values for already answered questions, and if not found, ask newly. teach also users how to "reset" (delete such file) to have all questions appear again
Comment 1 Alon Bar-Lev 2013-09-12 04:30:24 EDT
(In reply to Jiri Belka from comment #0)
> Actual results:
> primitive, asking always the same questions

Please explain some more what questions are you being asked when upgrading.
Comment 2 Jiri Belka 2013-09-12 07:19:34 EDT
* Would you like transactions from the Red Hat Access Plugin sent from the RHEV Manager to be brokered through a proxy server? (Yes, No) [No]:
* Do you want Setup to continue, with amount of memory less than recommended? (Yes, No) [No]:
Comment 3 Alon Bar-Lev 2013-09-12 07:23:57 EDT
(In reply to Jiri Belka from comment #2)

From the generic statement all you have are two questions...

> * Would you like transactions from the Red Hat Access Plugin sent from the
> RHEV Manager to be brokered through a proxy server? (Yes, No) [No]:

This is coming from gss support plugin, please open a separate bug.

> * Do you want Setup to continue, with amount of memory less than
> recommended? (Yes, No) [No]:

This is dup of bug#993698, and should be resolved after you upgrade from your latest product.
Comment 4 Jiri Belka 2013-09-12 08:39:51 EDT
Done for first issue - BZ1007408.
Comment 5 Alon Bar-Lev 2013-09-12 09:08:22 EDT
Dup for the second one.

*** This bug has been marked as a duplicate of bug 993698 ***

Note You need to log in before you can comment on or make changes to this bug.