Bug 994174 - rhc tool does not always display CLIENT_* text from node via broker
rhc tool does not always display CLIENT_* text from node via broker
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jessica Forrester
libra bugs
:
: 995809 (view as bug list)
Depends On:
Blocks: 986838
  Show dependency treegraph
 
Reported: 2013-08-06 12:07 EDT by Jhon Honce
Modified: 2015-05-14 22:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:49:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jhon Honce 2013-08-06 12:07:49 EDT
Description of problem:
The rhc tool does not always display error messages from the node coming back in the API payload via the broker

Version-Release number of selected component (if applicable):


How reproducible:
Using 'rhc app restart app001', if the cartridge issues a CLIENT_MESSAGE it will not be displayed

Steps to Reproduce:
1.
2.
3.

Actual results:
CLIENT_MESSAGE ignored in some cases

Expected results:
CLIENT_MESSAGE should always be displayed if text included in API payload

Additional info:
Comment 1 Jhon Honce 2013-08-12 20:39:06 EDT
CLIENT_ERROR is also not reported as expected.
Comment 2 Jhon Honce 2013-08-16 14:46:01 EDT
*** Bug 995809 has been marked as a duplicate of this bug. ***
Comment 3 openshift-github-bot 2013-08-21 15:53:30 EDT
Commit pushed to master at https://github.com/openshift/rhc

https://github.com/openshift/rhc/commit/28541a07d1858eac7ba425b79b9306843c12e0f8
Bug 994174 - rhc not displaying CLIENT_MESSAGE returned by broker
Comment 4 Jessica Forrester 2013-08-21 15:55:22 EDT
Fixed in https://github.com/openshift/rhc/pull/442

All CLIENT_MESSAGEs will be displayed in the warning yellow.

No change was made for CLIENT_ERRORs.  If a CLIENT_ERROR exists the broker should not be returning a success status code. If an error status code is returned rhc displays the CLIENT_ERRORs.
Comment 5 Wei Sun 2013-08-22 01:13:54 EDT
Verified on devenv-stage_448, rhc is 1.13.5

Step:
1.Create an app 
2.Generate a large file in data dir
3.Show app gears info via CLI

Result:
[wsun@dhcp-8-229 dev]$ rhc app-show phpt --gears
ID                       State                              Cartridges Size  SSH URL
------------------------ ---------------------------------- ---------- ----- -----------------------------------------------------------
5215989a427bc9072800000c started                            php-5.3    small 5215989a427bc9072800000c@phpt-wsundevstg448.dev.rhcloud.com
                         CLIENT_MESSAGE: Warning gear
                         5215989a427bc9072800000c is using
                         92.84477233886719 of disk quota

Note You need to log in before you can comment on or make changes to this bug.