Bug 994233 - [Doc][RFE] creating a network from the command line doesn't work
[Doc][RFE] creating a network from the command line doesn't work
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Getting_Started_Guide (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: 5.0 (RHEL 7)
Assigned To: Bruce Reeler
ecs-bugs
: Documentation, FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 15:54 EDT by Scott Merrill
Modified: 2014-10-30 18:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-23 00:00:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Merrill 2013-08-06 15:54:55 EDT
Document URL: https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/html/Getting_Started_Guide/sect-Working_with_Quantum_Networking.html

Section Number and Name: 7.8.1. Creating a Network

Describe the issue: Creating a network fails.

# source ~/keystonerc_admin
[~(keystone_admin)]# quantum net-create public01 --router:external True --provider:network_type flat --provider:physical_network public01
Invalid input for operation: Unknown provider:physical_network public01.


Suggestions for improvement: 

I assume since I'm using a "local" network type, rather than a "flat" network type, this is failing. The documentation lacks information on what I need to do to change the network type appropriately in order for the above command to succeed.
Comment 2 Summer Long 2013-08-08 19:53:09 EDT
Hi Ryan, 
It looks to me like the reporter is using a physical network name that doesn't exist. That physical network should be listed in the /etc/hosts file? Or how can they confirm that they're using a valid name?

But to make the documentation clearer, it looks like we could add examples for each type. Can you confirm that only the local, flat, and vlan types are currently supported (not gre)?

thanks, Summer
Comment 3 Summer Long 2013-08-09 01:38:04 EDT
Brent, Ryan thought you might be able to answer this. thanks, Summer
Comment 4 Bruce Reeler 2013-11-27 01:09:27 EST
Needinfo Marun Newby. 

Please see Summer's Q in comment 2.

(From the link in comment 0 this is a neutron related issue, not nova networking, so setting needinfo to Maru Newby.)
Comment 5 Maru Newby 2013-11-27 02:45:23 EST
Provider networks aren't my area of expertise, reassigning to Bob.
Comment 6 Bob Kukura 2013-11-27 12:49:42 EST
(In reply to Need Real Name from comment #0)
> Document URL:
> https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/html/
> Getting_Started_Guide/sect-Working_with_Quantum_Networking.html
> 
> Section Number and Name: 7.8.1. Creating a Network
> 
> Describe the issue: Creating a network fails.
> 
> # source ~/keystonerc_admin
> [~(keystone_admin)]# quantum net-create public01 --router:external True
> --provider:network_type flat --provider:physical_network public01
> Invalid input for operation: Unknown provider:physical_network public01.

This error means that the physical network "public01" is not listed in network_vlan_ranges on the node where quantum-server runs. Creating a provider network of type flat or vlan requires specifying a physical network that is listed in network_vlan_ranges. Its OK to use:

network_vlan_ranges = public01,public02

or something like that, with no ranges of VLAN tags specified. This makes the physical networks available for flat or vlan provider networks without making VLANs on those physical networks available as tenant networks.

> 
> 
> Suggestions for improvement: 
> 
> I assume since I'm using a "local" network type, rather than a "flat"
> network type, this is failing. The documentation lacks information on what I
> need to do to change the network type appropriately in order for the above
> command to succeed.

The tenant_network_type is really orthogonal to anything having to do with enabling provider networks. You should be able to use flat or vlan provider networks in combination with any type of tenant network (vlan, local, gre). Unfortunately, bug 1019044 causes packstack to ignore CONFIG_NEUTRON_OVS_VLAN_RANGES, CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS, and CONFIG_NEUTRON_OVS_BRIDGE_IFACES for certain settings of CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE.

Is this clarification sufficient, or does the documentation need to be updated to clarify the need to set network_vlan_ranges to include physical networks used for provider networks?
Comment 14 Bruce Reeler 2014-05-23 00:00:19 EDT
The whole openstack neworking thing has now moved to End User Guide, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.