This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 994385 - Invisible text not preserved by pdfwrite
Invisible text not preserved by pdfwrite
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ghostscript (Show other bugs)
5.9
Unspecified Unspecified
low Severity unspecified
: rc
: ---
Assigned To: Tim Waugh
QE Internationalization Bugs
: i18n, Patch
Depends On:
Blocks: 994452
  Show dependency treegraph
 
Reported: 2013-08-07 03:38 EDT by Simon Matter
Modified: 2013-11-01 08:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 994452 (view as bug list)
Environment:
Last Closed: 2013-11-01 08:10:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PDF with invisible text (94.75 KB, application/pdf)
2013-08-07 08:04 EDT, Simon Matter
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Ghostscript 691605 None None None Never

  None (edit)
Description Simon Matter 2013-08-07 03:38:53 EDT
Description of problem:
Running gs with pdfwrite on a scanned and OCR'ed PDF file the invisible text, which is used for copy/paste, is not preserved in the output file.

Version-Release number of selected component (if applicable):
ghostscript-8.70-14.el5_8.1

How reproducible:
always

Steps to Reproduce:
1. gs -dBATCH -dNOPAUSE -q -sDEVICE=pdfwrite -sOutputFile=all.pdf 201308070*.pdf
2.
3.

Actual results:
Some or all invisible text is missing in all.pdf (depending on the kind of font used in the input files)

Expected results:
All invisible text should still be in all.pdf

Additional info:
See the ghostscript bug for more info. The upstream commit is here http://ghostscript.com/pipermail/gs-cvs/2010-October/011807.html

I've tested the patch and it fixes the issue mentioned above.

Regards,
Simon
Comment 1 Tim Waugh 2013-08-07 06:28:40 EDT
Thank you for the report.

Are you able to attach a small example document that reproduces the problem?
Comment 2 Simon Matter 2013-08-07 08:04:34 EDT
Created attachment 783858 [details]
PDF with invisible text

If the file is run through ghostscript like this

gs -dBATCH -dNOPAUSE -q -sDEVICE=pdfwrite -sOutputFile=test-gs.pdf test.pdf

the output file doesn't include the invisible text anymore.
Comment 3 RHEL Product and Program Management 2013-08-07 10:39:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Tim Waugh 2013-11-01 08:10:19 EDT
This bug has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative.

This issue is being tracked for Red Hat Enterprise Linux 6 as bug #994452.

Note You need to log in before you can comment on or make changes to this bug.