Bug 994452 - Invisible text not preserved by pdfwrite
Invisible text not preserved by pdfwrite
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ghostscript (Show other bugs)
6.4
Unspecified Unspecified
low Severity unspecified
: rc
: ---
Assigned To: Tim Waugh
QE Internationalization Bugs
: i18n, Patch
Depends On: 994385
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 06:26 EDT by Tim Waugh
Modified: 2015-07-22 02:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: ghostscript-8.70-20.el6
Doc Type: Bug Fix
Doc Text:
Cause: Text intended for rendering in mode 3 (invisible) was not included in PDF output from pdfwrite device. Consequence: Copy and paste from documents with invisible text (such as OCR output) did not work. Fix: Mode 3 text is now included. Result: Copy and paste for invisible text now works.
Story Points: ---
Clone Of: 994385
Environment:
Last Closed: 2015-07-22 02:50:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ghostscript 691605 None None None Never

  None (edit)
Description Tim Waugh 2013-08-07 06:26:44 EDT
This bug also affects Red Hat Enterprise Linux 6.4.

+++ This bug was initially created as a clone of Bug #994385 +++

Description of problem:
Running gs with pdfwrite on a scanned and OCR'ed PDF file the invisible text, which is used for copy/paste, is not preserved in the output file.

Version-Release number of selected component (if applicable):
ghostscript-8.70-14.el5_8.1

How reproducible:
always

Steps to Reproduce:
1. gs -dBATCH -dNOPAUSE -q -sDEVICE=pdfwrite -sOutputFile=all.pdf 201308070*.pdf
2.
3.

Actual results:
Some or all invisible text is missing in all.pdf (depending on the kind of font used in the input files)

Expected results:
All invisible text should still be in all.pdf

Additional info:
See the ghostscript bug for more info. The upstream commit is here http://ghostscript.com/pipermail/gs-cvs/2010-October/011807.html

I've tested the patch and it fixes the issue mentioned above.

Regards,
Simon
Comment 1 RHEL Product and Program Management 2013-10-13 22:49:18 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 21 errata-xmlrpc 2015-07-22 02:50:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1343.html

Note You need to log in before you can comment on or make changes to this bug.