Bug 994456 - picture is cut off when the window is smaller than content, even with scaling=always
picture is cut off when the window is smaller than content, even with scaling...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 1028934 1029377 1066072 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 06:33 EDT by Kamil Páral
Modified: 2014-02-28 13:27 EST (History)
8 users (show)

See Also:
Fixed In Version: virt-manager-0.10.0-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-28 13:27:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug demonstration video (589.64 KB, video/ogg)
2013-08-07 06:33 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-08-07 06:33:13 EDT
Created attachment 783796 [details]
bug demonstration video

Description of problem:
Please see the video. I have scaling mode = always, but my VM content is cut off on start if the height of the window is too small. I have to manually resize the window to force re-scaling of the content.

Worked OK in F18.

I'm using SPICE and QXL.

Version-Release number of selected component (if applicable):
libvirt-1.0.5.4-1.fc19.x86_64
libvirt-client-1.0.5.4-1.fc19.x86_64
libvirt-daemon-1.0.5.4-1.fc19.x86_64
libvirt-daemon-config-network-1.0.5.4-1.fc19.x86_64
libvirt-daemon-config-nwfilter-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-interface-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-libxl-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-lxc-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-network-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-nodedev-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-nwfilter-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-qemu-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-secret-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-storage-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-uml-1.0.5.4-1.fc19.x86_64
libvirt-daemon-driver-xen-1.0.5.4-1.fc19.x86_64
libvirt-daemon-kvm-1.0.5.4-1.fc19.x86_64
libvirt-glib-0.1.6-1.fc19.x86_64
libvirt-python-1.0.5.4-1.fc19.x86_64
virt-install-0.10.0-1.fc19.noarch
virt-manager-0.10.0-1.fc19.noarch
virt-manager-common-0.10.0-1.fc19.noarch
virt-top-1.0.8-4.fc19.x86_64
virt-viewer-0.5.6-1.fc19.x86_64

ipxe-roms-qemu-20130517-2.gitc4bce43.fc19.noarch
libvirt-daemon-driver-qemu-1.0.5.4-1.fc19.x86_64
qemu-1.4.2-5.fc19.x86_64
qemu-common-1.4.2-5.fc19.x86_64
qemu-img-1.4.2-5.fc19.x86_64
qemu-kvm-1.4.2-5.fc19.x86_64
qemu-system-alpha-1.4.2-5.fc19.x86_64
qemu-system-arm-1.4.2-5.fc19.x86_64
qemu-system-cris-1.4.2-5.fc19.x86_64
qemu-system-lm32-1.4.2-5.fc19.x86_64
qemu-system-m68k-1.4.2-5.fc19.x86_64
qemu-system-microblaze-1.4.2-5.fc19.x86_64
qemu-system-mips-1.4.2-5.fc19.x86_64
qemu-system-or32-1.4.2-5.fc19.x86_64
qemu-system-ppc-1.4.2-5.fc19.x86_64
qemu-system-s390x-1.4.2-5.fc19.x86_64
qemu-system-sh4-1.4.2-5.fc19.x86_64
qemu-system-sparc-1.4.2-5.fc19.x86_64
qemu-system-unicore32-1.4.2-5.fc19.x86_64
qemu-system-x86-1.4.2-5.fc19.x86_64
qemu-system-xtensa-1.4.2-5.fc19.x86_64
qemu-user-1.4.2-5.fc19.x86_64

spice-glib-0.20-2.fc19.x86_64
spice-gtk-0.20-2.fc19.x86_64
spice-gtk3-0.20-2.fc19.x86_64
spice-gtk-python-0.20-2.fc19.x86_64
spice-server-0.12.3-1.fc19.x86_64

xorg-x11-drv-qxl-0.1.1-0.11.20130514git77a1594.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. make the window too small in height, but wide enough (usual case for 12" laptop monitors)
2. set scale mode = always
3. boot F19 Live, for example

Actual results:
content is not scaled

Expected results:
content is scaled
Comment 1 Kamil Páral 2013-08-07 06:34:34 EDT
I'd also like to point out that a reasonable scaling mode "only if bigger" would be extremely welcome - bug 969416.
Comment 2 Cole Robinson 2014-01-29 13:56:07 EST
*** Bug 1028934 has been marked as a duplicate of this bug. ***
Comment 3 Cole Robinson 2014-01-29 13:56:51 EST
*** Bug 1029377 has been marked as a duplicate of this bug. ***
Comment 4 Cole Robinson 2014-01-30 12:50:38 EST
Thanks for the reports, fixed upstream now:

commit b9bbf4686dbaa6e0ade09464973dc5d5d383c25c
Author: Cole Robinson <crobinso@redhat.com>
Date:   Wed Jan 29 16:58:34 2014 -0500

    console: Bunch of scaling fixes (bz 969416)
    
    Make scaling=always work correctly with spice
    Make 'resize to vm' work with scaling enabled
    Simplify it all
Comment 5 Cole Robinson 2014-02-17 12:05:55 EST
*** Bug 1066072 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2014-02-17 12:40:44 EST
virt-manager-0.10.0-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/virt-manager-0.10.0-5.fc19
Comment 7 Fedora Update System 2014-02-18 08:27:31 EST
Package virt-manager-0.10.0-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.10.0-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2664/virt-manager-0.10.0-5.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-02-28 13:27:06 EST
virt-manager-0.10.0-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.