Bug 994491 - "lvconvert -r" does not work
"lvconvert -r" does not work
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Zdenek Kabelac
cluster-qe@redhat.com
:
: 1006025 (view as bug list)
Depends On:
Blocks: 1006025
  Show dependency treegraph
 
Reported: 2013-08-07 07:40 EDT by Xiaowei Li
Modified: 2016-01-18 13:06 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1006025 (view as bug list)
Environment:
Last Closed: 2016-01-18 13:06:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaowei Li 2013-08-07 07:40:57 EDT
Description of problem:
lvconvert does not change the read_ahead to zero after executing "lvconvert --thinpool vg/pool -r none"

"lvchange -r none" works well

Version-Release number of selected component (if applicable):
lvm2-2.02.99-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.                                

[root@dhcp12-156 tc]# lvs vg -oname,lv_read_ahead
  LV   Rahead
  pool     auto 

[root@dhcp12-156 tc]# lvconvert --thinpool vg/pool -r none
  Logical volume "pool_tmeta" created
  Logical volume "lvol0" created
  Converted vg/pool to thin pool.
  
[root@dhcp12-156 tc]# lvs vg -oname,lv_read_ahead
  LV   Rahead
  pool     auto 

[root@dhcp12-156 tc]# lvchange -r none vg/pool
  Logical volume "pool" changed.

[root@dhcp12-156 tc]# lvs vg -oname,lv_read_ahead
  LV   Rahead
  pool     0 

[root@dhcp12-156 tc]# ls -l /dev/mapper/vg-pool
lrwxrwxrwx. 1 root root 7 Aug  7 07:17 /dev/mapper/vg-pool -> ../dm-5
  
[root@dhcp12-156 tc]# cat /sys/block/dm-5/queue/read_ahead_kb 
0


Actual results:


Expected results:


Additional info:
Comment 4 Corey Marthaler 2013-09-09 15:49:52 EDT
Yes, this exists on rhel6.5 as well.
Comment 5 Ludek Smid 2014-06-26 06:47:34 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.
Comment 6 Ludek Smid 2014-06-26 07:16:11 EDT
The comment above is incorrect. The correct version is bellow.
I'm sorry for any inconvenience.
---------------------------------------------------------------

This request was NOT resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you need
to escalate this bug.
Comment 7 Zdenek Kabelac 2014-11-26 05:02:54 EST
There is currently no meaning behind  read-ahead setting for thin-pool.
So before this BZ is fixed we need to check how to deal with this setting in kernel driver first.
Comment 10 Jonathan Earl Brassow 2015-07-22 09:24:14 EDT
This bug will not be resolved for 7.2.  The read-ahead setting for thin-pools makes no sense really, and this bug may simply be CLOSED NOTABUG.

However, there may be some utility in setting read-ahead for a pool, in that thinLVs might inherit the setting from the pool.  (Although, that is better suited to an LVM config setting probably.)  I'll leave this open for a while for some discussion.
Comment 12 Jonathan Earl Brassow 2016-01-18 13:03:43 EST
*** Bug 1006025 has been marked as a duplicate of this bug. ***
Comment 13 Jonathan Earl Brassow 2016-01-18 13:06:27 EST
There is not determination as to what read-ahead should mean for thin-pools and no discussion to resolve it.  I'm closing this bug WONTFIX.  It can be reopened if it is determined that this is a problem.  (See comment 7 and comment 10 for reference.)

Note You need to log in before you can comment on or make changes to this bug.