Bug 994613 - spice-xpi: Add Proxy property
spice-xpi: Add Proxy property
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-xpi (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 11:35 EDT by Uri Lublin
Modified: 2013-11-21 16:40 EST (History)
4 users (show)

See Also:
Fixed In Version: spice-xpi-2.7-24.el6
Doc Type: Enhancement
Doc Text:
Feature: Add proxy support to spice-xpi Reason: Allow to set a proxy to use for SPICE connection when using the spice-xpi browser plugin (for example when opening a console from the RHEV-M portal) Result (if any): It's now possible for spice-xpi to pass proxy setting to the SPICE client it spawns
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:40:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uri Lublin 2013-08-07 11:35:28 EDT
Description of problem:
Allow controller to pass proxy information to the spice client (remote-viewer).

This matches spice-active-x bug 909496.
The following is copied from bug 909496:

property name is "Proxy", it's a string with the same content description as environment variable or the virt-viewer configuration file. Also described in spice-protocol:

    The value must be of the form [protocol://]<host>[:port]
    
    The proxy string may be specified with a protocol:// prefix to specify
    alternative proxy protocols.
    
    If no protocol is specified in the proxy string or if the string
    doesn't match a supported one, the proxy will be treated as a HTTP
    proxy.

    If no port is specified port 3128 is used (the default port for squid)


The string passed from RHEVM is forwarded to the client without any validation.
Comment 2 Uri Lublin 2013-08-07 11:52:17 EDT
A patch is available upstream. -> POST
http://cgit.freedesktop.org/spice/spice-xpi/commit/?id=e518db3700ed23d3ccc7026b922b236158e501cc
Comment 5 errata-xmlrpc 2013-11-21 16:40:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1667.html

Note You need to log in before you can comment on or make changes to this bug.