Bug 994874 - [vdsm] Stopping a vm fails with "RuntimeError: dictionary changed size during iteration"
[vdsm] Stopping a vm fails with "RuntimeError: dictionary changed size during...
Status: CLOSED DUPLICATE of bug 994551
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
: Regression, TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 03:30 EDT by Gadi Ickowicz
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 03:40:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine + vdsm logs (10.94 MB, application/x-bzip)
2013-08-08 03:30 EDT, Gadi Ickowicz
no flags Details

  None (edit)
Description Gadi Ickowicz 2013-08-08 03:30:48 EDT
Created attachment 784242 [details]
engine + vdsm logs

Description of problem:
Stopping a vm fails with "RuntimeError: dictionary changed size during iteration". 

Version-Release number of selected component (if applicable):
vdsm-4.12.0-37.gitfd6a1b7.el6ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create a vm and install OS with guest agent on it
2. Stop the vm

Actual results:
vdsm fails to stop the vm with the following exception:
Thread-483::ERROR::2013-08-08 05:44:20,705::BindingXMLRPC::993::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 979, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 211, in vmDestroy
    return vm.destroy()
  File "/usr/share/vdsm/API.py", line 322, in destroy
    res = v.destroy()
  File "/usr/share/vdsm/vm.py", line 4281, in destroy
    response = self.releaseVm()
  File "/usr/share/vdsm/vm.py", line 4249, in releaseVm
    self.cif.removeVmFromMonitoredDomains(self.id)
  File "/usr/share/vdsm/clientIF.py", line 125, in removeVmFromMonitoredDomains
    for dom in self.domainVmIds:
RuntimeError: dictionary changed size during iteration


Expected results:
VM should stop

Additional info:
Comment 1 Haim 2013-08-08 03:40:00 EDT

*** This bug has been marked as a duplicate of bug 994551 ***

Note You need to log in before you can comment on or make changes to this bug.