Bug 9949 - rsync fails with message "rsync: unrecognized option `--max-delete=1000000000'"
Summary: rsync fails with message "rsync: unrecognized option `--max-delete=1000000000'"
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rsync   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 9995 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-04 03:12 UTC by Adrian Likins
Modified: 2014-03-17 02:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-07 20:48:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace showing rsync freaking out (4.93 KB, text/plain)
2000-03-04 03:13 UTC, Adrian Likins
no flags Details

Description Adrian Likins 2000-03-04 03:12:40 UTC
As mentioned in the summary, rsync seems to sometimes fail
with "rsync: unrecognized option `--max-delete=1000000000'"

Of course, to make it interesting, it should be noted that
this option is _not_ part of the commandline, and is not
part of an alias.

[alikins@slag RDF]$ which rsync
/usr/bin/rsync
[alikins@slag RDF]$ /usr/bin/rsync --delete -r -v --rsh=/usr/bin/ssh  .
rdf@admin.portal.redhat.com:RDF
rsync: unrecognized option `--max-delete=1000000000'
unexpected EOF in read_timeout

rsync seem to rebuild its commandline sometimes to
include the "--max-delete=100000000" even if you didnt
specify it, then execve's the new commandline. Very weird.

To make it more fun, sometimes it will work on other directories,
but fail if straced.

ie:

[alikins@slag /tmp]$ /usr/bin/rsync --delete -r -v --rsh=/usr/bin/ssh  .
alikins@swoop.support.redhat.com:/tmp

but stracing it will cause the error above as well.

Sometimes it works, sometimes it doesnt.

Also note, that despite what the output of `rsync -h` claims,
giving "--max-delete=1000" on the commandline doesnt work either.

I'll attach a strace...

Comment 1 Adrian Likins 2000-03-04 03:13:59 UTC
Created attachment 139 [details]
strace showing rsync freaking out

Comment 2 Jeff Johnson 2000-03-04 17:38:59 UTC
The max-delete option was a patch from Daniel Veillard to minimize
damage when the source of a rsync had, for example, "disk problems".
I believe that the patch has been rolled into the latest rsync, albeit
with syntax changes. Judging from rsync traffic, there may be other
problems with rsync-2.4.1, so an update/errata will probably be necessary.

As a work around, you can always install the 6.1 package with Daniel Veillard's
patch.

Comment 3 Bill Nottingham 2000-03-04 18:09:59 UTC
Um, your strace is broken and dying because it's trying
to exec ssh under strace (ssh is setuid, so it won't work.)

Comment 4 Bill Nottingham 2000-03-04 18:11:59 UTC
The error you are getting is from the rsync process
running on the other end of the connection. Upgrading
rsync on that end should stop the problem.

Comment 5 Bill Nottingham 2000-03-06 16:24:59 UTC
*** Bug 9995 has been marked as a duplicate of this bug. ***

Comment 6 Bill Nottingham 2000-03-07 20:48:59 UTC
Fixed in rsync-2.4.1-2.


Note You need to log in before you can comment on or make changes to this bug.