Bug 994940 - regression: '--excludepkgs' statement ignored in kickstart file
regression: '--excludepkgs' statement ignored in kickstart file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 995526 997116 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 05:32 EDT by Enrico Scholz
Modified: 2014-02-21 14:17 EST (History)
10 users (show)

See Also:
Fixed In Version: anaconda-20.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-21 14:17:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2013-08-08 05:32:43 EDT
Description of problem:

The '--excludepkgs' switch of the 'repo' option seems to be ignored by recent anaconda.  It worked fine with previous versions.

E.g. I have

| repo --name=fedora-core ... --excludepkgs=cfengine
| repo --name=local ...

where the 'local' repository provides 'cfengine-2.2.10'. After installation, cfengine-3.3.0 from the 'fedora-core' repository is installed.


Version-Release number of selected component (if applicable):

Fedora 19 installer
Comment 1 Chris Lumens 2013-08-21 15:25:52 EDT
Can you please attach /tmp/packaging.log and /tmp/yum.repos.d/fedora-core.* to this bug report?  For that matter, where is fedora-core configured to install from?  Is that your own local repo?
Comment 2 Chris Lumens 2013-08-21 15:33:43 EDT
*** Bug 995526 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2013-08-21 15:34:57 EDT
I'm guessing your repo config file simply will not contain an exclude= line.  Can you confirm that suspicion?  I do not need the log files attached, turns out.
Comment 4 Chris Lumens 2013-08-21 16:11:41 EDT
*** Bug 997116 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2013-08-21 16:15:17 EDT
All kickstart repo problems appear to be somehow related to the repo getting removed in source.py:_update_payload_repos.

Note You need to log in before you can comment on or make changes to this bug.