Bug 997116 - "repo" options not written to /root/anaconda-ks.cfg
"repo" options not written to /root/anaconda-ks.cfg
Status: CLOSED DUPLICATE of bug 994940
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 13:39 EDT by Steve Tyler
Modified: 2013-08-21 16:11 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 16:11:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks-bz995526.cfg kickstart file having "repo" options (514 bytes, text/plain)
2013-08-14 13:39 EDT, Steve Tyler
no flags Details
/root/anaconda-ks.cfg without "repo" options (754 bytes, text/plain)
2013-08-14 13:40 EDT, Steve Tyler
no flags Details
packaging.log (71.55 KB, text/plain)
2013-08-14 15:06 EDT, Steve Tyler
no flags Details
anaconda.log (11.87 KB, text/plain)
2013-08-14 15:11 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2013-08-14 13:39:03 EDT
Created attachment 786631 [details]
ks-bz995526.cfg kickstart file having "repo" options

Description of problem:
The "repo" options from a user-defined kickstart file are not written to /root/anaconda-ks.cfg.

Version-Release number of selected component (if applicable):
Fedora-19-x86_64-DVD.iso

$ sudo repoquery anaconda pykickstart --repoid=fedora --releasever=19
anaconda-0:19.30.13-1.fc19.x86_64
pykickstart-0:1.99.32-1.fc19.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Start installer DVD:
$ qemu-kvm -m 4096 -hda f19-test-2.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on

2. Append kickstart option to kernel command-line:
ks=nfs:walnut.lan:/var/tmp/kickstart/ks-bz995526.cfg

3. Complete install and reboot into installed system.

4. # cat /root/anaconda-ks.cfg

Actual results:
No "repo" options are in /root/anaconda-ks.cfg.

Expected results:
All "repo" options from the input kickstart file are in /root/anaconda-ks.cfg.

Additional info:
The bz number in the input kickstart file is for this bug:
Bug 995526 - regression: --cost ignored in kickstart file
Comment 1 Steve Tyler 2013-08-14 13:40:41 EDT
Created attachment 786632 [details]
/root/anaconda-ks.cfg without "repo" options
Comment 2 Chris Lumens 2013-08-14 13:42:41 EDT
What evidence do you have that this is pykickstart, and not anaconda?
Comment 3 Steve Tyler 2013-08-14 13:48:18 EDT
Why are you asking -- reassign it to libreoffice, if you want ...
Comment 4 Steve Tyler 2013-08-14 13:55:00 EDT
This bug does not occur with F18: Bug 995526, Comment 21.
Comment 5 Chris Lumens 2013-08-14 13:56:52 EDT
I'm asking because I enjoy wasting my time.

This is almost certainly an anaconda bug, I just wanted some more data on that before I reassigned it.  Thanks for continuing to be so very helpful.
Comment 6 Steve Tyler 2013-08-14 14:00:50 EDT
There aren't any release tags for pykickstart:
https://git.fedorahosted.org/cgit/pykickstart.git/log/

You got a detailed bug report, everything after is whining ...
Comment 7 Steve Tyler 2013-08-14 14:24:57 EDT
These are the only lines in the diff between pykickstart for F18 and F19 explicitly concerning repos:

$ diff -ur r1.99.22-1/ r1.99.32-1/ | grep -i repo
+	PYTHONPATH=. coverage report --show-missing --include='pykickstart/*'
 "Report-Msgid-Bugs-To: \n"
-import mouse, multipath, network, partition, raid, reboot, repo, rescue, rootpw
+import mouse, multipath, network, partition, raid, realm, reboot, repo, rescue, rootpw
         "repo": repo.F15_Repo,
+        "repo": repo.F15_Repo,
         "repo": repo.F15_Repo,
+        "RepoData": repo.F15_RepoData,
         "RepoData": repo.F15_RepoData,
+- Fix a bug in logvol duplicate reporting (#924579, mhuth). (clumens)
+- Make sure tests can run and report import errors (bcl)

==
$ sudo repoquery anaconda pykickstart --repoid=fedora --releasever=18
anaconda-0:18.37.11-1.fc18.x86_64
pykickstart-0:1.99.22-1.fc18.noarch

$ sudo repoquery anaconda pykickstart --repoid=fedora --releasever=19
anaconda-0:19.30.13-1.fc19.x86_64
pykickstart-0:1.99.32-1.fc19.noarch
Comment 8 Peter Jones 2013-08-14 14:29:37 EDT
Steve, there's no need to make accusations of "whining" or sarcastically suggesting to re-assign to other unrelated packages.  Chris was asking if you'd done more diagnostic work, because you initially assigned it to a package that, while related to the problem, was not obviously the culprit.  Since you'd done such a strange thing, it seemed reasonable that maybe you'd forgotten to tell him some diagnostic task you'd done.

Please do try and understand that we're trying to solve this together, and if we ask questions, it's because we think that knowing the answers for them is helpful in solving the problem.
Comment 9 Steve Tyler 2013-08-14 14:46:27 EDT
Peter, you are scolding ...
Comment 10 Steve Tyler 2013-08-14 15:06:48 EDT
Created attachment 786667 [details]
packaging.log

The attached packaging.log is the only log file that explicitly mentions a repo by name:

$ grep -l updates-kern *log
packaging.log
Comment 11 Steve Tyler 2013-08-14 15:11:59 EDT
Created attachment 786669 [details]
anaconda.log
Comment 12 Chris Lumens 2013-08-21 16:11:41 EDT

*** This bug has been marked as a duplicate of bug 994940 ***

Note You need to log in before you can comment on or make changes to this bug.