Bug 995121 - GUI: calendar icon on s390x and ppc64 machines is not displayed
GUI: calendar icon on s390x and ppc64 machines is not displayed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: John Sefler
John Sefler
:
: 995120 995122 (view as bug list)
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-08-08 11:08 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:18:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
expected Calendar icon is now renderred on a s390 server (46.56 KB, image/png)
2014-02-11 09:40 EST, John Sefler
no flags Details
expected Calendar icon is now renderred on a ppc64 server (39.17 KB, image/png)
2014-02-11 09:45 EST, John Sefler
no flags Details

  None (edit)
Description Sharath Dwaral 2013-08-08 11:08:03 EDT
Description of problem:
GUI: calendar icon on s390x machine not displayed

Version-Release number of selected component (if applicable):
rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.8.19-1.el5
python-rhsm-1.8.16-1.el5
subscription-manager-firstboot-1.8.19-1.el5
subscription-manager-migration-1.8.19-1.el5
subscription-manager-1.8.19-1.el5
subscription-manager-debuginfo-1.8.19-1.el5

How reproducible:
always

Steps to Reproduce:
# ssh -XYC root@ibm-z10-14.rhts.eng.bos.redhat.com
# subscription-manager-gui

Actual results:
See Attachment

Expected results:
calendar icon should be displayed

Additional info:
Comment 2 Sharath Dwaral 2013-08-13 10:36:43 EDT
*** Bug 995122 has been marked as a duplicate of this bug. ***
Comment 3 Sharath Dwaral 2013-08-13 10:38:41 EDT
The same problem also exists on pp64 machine.
Comment 4 Carter Kozak 2013-08-14 12:44:42 EDT
*** Bug 995120 has been marked as a duplicate of this bug. ***
Comment 5 Adrian Likins 2014-01-31 14:48:39 EST
Looks like this is a missing dependency on gnome-icon-them package.

I suspect default desktop installs always get it anyway, but not minimal server installs. 

Needs added to the spec.
Comment 7 Adrian Likins 2014-02-03 16:29:23 EST
in master:

commit 00f3a053166187b631a660623fc169e3da0218bd
Author: Adrian Likins <alikins@redhat.com>
Date:   Fri Jan 31 14:51:49 2014 -0500

    995121: require gnome-icon-theme for calendar icon
    
    The icon used for the calendar widget is part of
    gnome-icon-theme, which was not a package dep.
Comment 9 John Sefler 2014-02-11 09:40:39 EST
Created attachment 861798 [details]
expected Calendar icon is now renderred on a s390 server

Verifying Version...

[root@ibm-z10-74 ~]# rpm -qa | grep subscription-manager
subscription-manager-1.10.13-1.el7.s390x
subscription-manager-gui-1.10.13-1.el7.s390x

[root@ibm-z10-74 ~]# rpm -q --requires subscription-manager-gui
/bin/sh
/bin/sh
/bin/sh
/usr/bin/python
dbus-x11
gnome-icon-theme          <======= VERIFIED
gnome-python2
gnome-python2-canvas
libatk-1.0.so.0()(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2)(64bit)
libcairo.so.2()(64bit)
libdbus-1.so.3()(64bit)
libdbus-glib-1.so.2()(64bit)
libfontconfig.so.1()(64bit)
libfreetype.so.6()(64bit)
libgconf-2.so.4()(64bit)
libgdk-x11-2.0.so.0()(64bit)
libgdk_pixbuf-2.0.so.0()(64bit)
libgio-2.0.so.0()(64bit)
libglib-2.0.so.0()(64bit)
libgobject-2.0.so.0()(64bit)
libgtk-x11-2.0.so.0()(64bit)
libnotify.so.4()(64bit)
libpango-1.0.so.0()(64bit)
libpangocairo-1.0.so.0()(64bit)
libpangoft2-1.0.so.0()(64bit)
libpthread.so.0()(64bit)
librsvg2(s390-64)
pygtk2
pygtk2-libglade
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)
scrollkeeper
scrollkeeper
subscription-manager = 1.10.13-1.el7
usermode-gtk
rpmlib(PayloadIsXz) <= 5.2-1
[root@ibm-z10-74 ~]# 


VERIFIED: See attached screenshot of an s390 server with expected calendar icon.
Comment 10 John Sefler 2014-02-11 09:45:30 EST
Created attachment 861799 [details]
expected Calendar icon is now renderred on a ppc64 server

Also Verifying on a ppc64 server...

[root@ibm-p720-01-lp2 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.10.13-1.el7.ppc64

VERIFIED: See attached screenshot of a ppc64 server with expected calendar icon.
Comment 11 Ludek Smid 2014-06-13 05:18:10 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.