Bug 995525 - oo-last-access script chokes on /etc/openshift/node.conf with only space in configuration line
oo-last-access script chokes on /etc/openshift/node.conf with only space in c...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On: 997129
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 11:36 EDT by John Keck
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If a line in the /etc/openshift/node.conf file contained only a single space, the oo-last-access script would fail to run. The parser has been fixed in the current release of OpenShift Enterprise, and the oo-last-access script now runs correctly.
Story Points: ---
Clone Of:
: 997129 (view as bug list)
Environment:
Build: CSProcessor Builder Version 1.12 Build Name: 20822, Administration Guide-null-1.2 Build Date: 06-08-2013 11:53:32 Topic ID: 20819-478581 [Latest]
Last Closed: 2013-09-05 09:24:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Keck 2013-08-09 11:36:48 EDT
Title: oo-last-access

Describe the issue:

When running oo-last-access from the command line, if the /etc/openshift/node.conf has a configuration line that contains only a space you get the following stack trace: 

/usr/sbin/oo-last-access:134:in `block in source_file': undefined method `split' for nil:NilClass (NoMethodError)
	from /usr/sbin/oo-last-access:127:in `foreach'
	from /usr/sbin/oo-last-access:127:in `source_file'
	from /usr/sbin/oo-last-access:151:in `block in <main>'
	from /usr/sbin/oo-last-access:144:in `call'
	from /usr/sbin/oo-last-access:144:in `single_instance'
	from /usr/sbin/oo-last-access:150:in `<main>'


Suggestions for improvement:


Additional information:
Comment 3 Gaoyun Pei 2013-08-16 03:07:46 EDT
Test this bug on puddle 1.2/2013-08-15.2

After setting up the OSE env, oo-last-access couldn't work at all
[root@node1 ~]# oo-last-access 
/usr/sbin/oo-last-access:129:in `source_file': undefined method `params' for #<OpenShift::Config:0x000000010480c0> (NoMethodError)
	from /usr/sbin/oo-last-access:144:in `block in <main>'
	from /usr/sbin/oo-last-access:137:in `call'
	from /usr/sbin/oo-last-access:137:in `single_instance'
	from /usr/sbin/oo-last-access:143:in `<main>'

So assign it back, thanks!
Comment 5 Gaoyun Pei 2013-08-21 01:34:53 EDT
Verify this on puddle: 1.2/2013-08-20.1

After adding lines that contains only a space in /etc/openshift/node.conf, oo-last-access could work.
Comment 8 errata-xmlrpc 2013-09-05 09:24:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1211.html

Note You need to log in before you can comment on or make changes to this bug.