Bug 997129 - oo-last-access script chokes on /etc/openshift/node.conf with only space in configuration line
oo-last-access script chokes on /etc/openshift/node.conf with only space in c...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks: 995525
  Show dependency treegraph
 
Reported: 2013-08-14 14:04 EDT by Brenton Leanhardt
Modified: 2015-05-14 19:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 995525
Environment:
Build: CSProcessor Builder Version 1.12 Build Name: 20822, Administration Guide-null-1.2 Build Date: 06-08-2013 11:53:32 Topic ID: 20819-478581 [Latest]
Last Closed: 2014-03-11 23:05:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-08-14 14:04:21 EDT
+++ This bug was initially created as a clone of Bug #995525 +++

Title: oo-last-access

Describe the issue:

When running oo-last-access from the command line, if the /etc/openshift/node.conf has a configuration line that contains only a space you get the following stack trace: 

/usr/sbin/oo-last-access:134:in `block in source_file': undefined method `split' for nil:NilClass (NoMethodError)
	from /usr/sbin/oo-last-access:127:in `foreach'
	from /usr/sbin/oo-last-access:127:in `source_file'
	from /usr/sbin/oo-last-access:151:in `block in <main>'
	from /usr/sbin/oo-last-access:144:in `call'
	from /usr/sbin/oo-last-access:144:in `single_instance'
	from /usr/sbin/oo-last-access:150:in `<main>'


Suggestions for improvement:


Additional information:

--- Additional comment from RHEL Product and Program Management on 2013-08-09 11:58:43 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 1 openshift-github-bot 2013-08-14 18:07:27 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/e2bba771e5b8ced31bc5c6229c715f4625423116
Bug 997129 - oo-last-access script chokes on /etc/openshift/node.conf with only space in configuration line
Comment 2 Dan McPherson 2014-02-25 19:07:56 EST
Brenton,  Was the above commit the fix for this bug?  Can we move it ON_QA?
Comment 3 Luke Meyer 2014-02-26 10:37:05 EST
Looks like it. Removed the cargo-culted parser code in favor of Config module.
Comment 4 Meng Bo 2014-02-27 05:48:04 EST
Checked on devenv_4428, after add new line with only a space to node.conf, oo-last-access can work fine.

Note You need to log in before you can comment on or make changes to this bug.