Bug 995617 - Openconnect not working any more.
Openconnect not working any more.
Status: CLOSED DUPLICATE of bug 980467
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 16:58 EDT by Slava
Modified: 2013-09-20 16:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 16:28:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Slava 2013-08-09 16:58:32 EDT
Network Manager/openconnect is show lock in right corner, but in menu is off.
And each time need reboot laptop to clear up the connection or restart network service.


Aug  9 16:53:54 j8p3zn1 NetworkManager[709]: <error> [1376081634.436278] [nm-vpn-connection.c:1374] get_secrets_cb(): Failed to request VPN secrets #3: (6) No agents were available for this request.
Aug  9 16:53:54 j8p3zn1 NetworkManager[709]: <info> Policy set 'Wired connection 2' (em1) as default for IPv4 routing and DNS.
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: JS ERROR: !!!   Exception was: TypeError: obj.active is undefined
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: JS ERROR: !!!     message = '"obj.active is undefined"'
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/status/network.js"'
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: JS ERROR: !!!     lineNumber = '1564'
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: JS ERROR: !!!     stack = '"([object GObject_Object])@/usr/share/gnome-shell/js/ui/status/network.js:1564
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: wrapper([object GObject_Object])@/usr/share/gjs-1.0/lang.js:213
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: ()@/usr/share/gnome-shell/js/ui/status/network.js:2031
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: wrapper()@/usr/share/gjs-1.0/lang.js:213
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: ([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gnome-shell/js/ui/status/network.js:2292
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: wrapper([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gjs-1.0/lang.js:213
Aug  9 16:53:54 j8p3zn1 gnome-session[2251]: "'
Aug  9 16:53:59 j8p3zn1 NetworkManager[709]: <info> VPN service 'openconnect' disappeared
Comment 1 David Woodhouse 2013-08-12 06:09:45 EDT
This is a well-known and long-standing gnome-shell bug. Probably a duplicate of bug 980467 or bug 967743 (or both).

Unfortunately I don't think it's likely to get fixed any time soon. Nobody really seems to be taking good care of gnome-shell these days.
Comment 2 Dan Williams 2013-09-20 16:28:49 EDT
I think the root cause is bug 980467 and gnome 698962.

*** This bug has been marked as a duplicate of bug 980467 ***

Note You need to log in before you can comment on or make changes to this bug.