Bug 995643 - Default gnome font (Cantarell) looks fuzzy in freetype 2.5.0
Default gnome font (Cantarell) looks fuzzy in freetype 2.5.0
Status: CLOSED DUPLICATE of bug 1035486
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
: Reopened
: 999143 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 21:25 EDT by sangu
Modified: 2014-11-12 10:37 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-12 10:37:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
freetype 2.5.0 vs 2.4.11 (65.71 KB, image/png)
2013-08-09 21:25 EDT, sangu
no flags Details

  None (edit)
Description sangu 2013-08-09 21:25:28 EDT
Created attachment 785048 [details]
freetype 2.5.0 vs 2.4.11

Description of problem:
After updating to freetype 2.5.0, hinting rendering is strange 

Version-Release number of selected component (if applicable):
2.5.0-3.fc20.

How reproducible:
always

Steps to Reproduce:
1. ftview -m "The quick brown fox jumps over the lazy dog." 24 "/usr/share/fonts/abattis-cantarell/Cantarell-Regular.otf" 
2. click "h" key
3.

Actual results:


Expected results:


Additional info:
Comment 1 sangu 2013-08-30 22:40:17 EDT
Only Cantarell font (GNOME Default UI font) looks fuzzy in freetype 2.5.0
See Also : bug 999143#c3
Comment 2 Akira TAGOH 2013-09-01 23:47:59 EDT
*** Bug 999143 has been marked as a duplicate of this bug. ***
Comment 3 Marek Kašík 2013-09-26 12:22:21 EDT
Hi Sangu,

the difference you see is the difference between old Freetype CFF engine and the new Adobe CFF engine (otf fonts). The switch happened in 2.4.12. You can find related posts here:

http://lists.nongnu.org/archive/html/freetype-devel/2013-05/msg00000.html
http://blogs.adobe.com/typblography/2013/05/adobe-contributes-cff-rasterizer-to-freetype.html
http://google-opensource.blogspot.cz/2013/05/got-cff.html

From my POV this is not a bug.

Regards

Marek
Comment 4 Pádraig Brady 2014-11-12 10:15:11 EST
The rendering of Cantarell is noticeably fuzzy,
and worse in thunderbird for example has different heights
for bold and non bold items, resulting in text jumping around
as you navigate over emails (changing them from unread to read).

This is a bug IMHO and should be fixed in the CFF engine
or at least moved to gnome, where a different default font should be chosen.
Comment 5 Pádraig Brady 2014-11-12 10:37:19 EST

*** This bug has been marked as a duplicate of bug 1035486 ***

Note You need to log in before you can comment on or make changes to this bug.