Bug 999143 - fuzzy fonts after upgrading to rawhide
fuzzy fonts after upgrading to rawhide
Status: CLOSED DUPLICATE of bug 995643
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 15:41 EDT by Elad Alfassa
Modified: 2013-09-01 23:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-01 23:47:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elad Alfassa 2013-08-20 15:41:37 EDT
Description of problem:
http://i.imgur.com/yx1n4iv.png
Almost all fonts are fuzzy, apart from text in xchat scrollback box, Gnome Web (webkitgtk) and gnome-terminal.

This happened after I upgraded to rawhide.

If this is the wrong component please direct me to the correct one. Thanks.
Comment 1 Elad Alfassa 2013-08-20 18:29:13 EDT
Further debugging suggests that it's cantarell specific, and downgrading fontconfig, pixman, cairo, and cantarell didn't help fix the problem.
Comment 2 Akira TAGOH 2013-08-20 22:59:46 EDT
Are you talking about antialiasing?

How does it look like on f19 say?

How did you estimate it is cantarell specific? even though you said downgrading cantarell didn't help??
Comment 3 Elad Alfassa 2013-08-21 04:08:30 EDT
I don't know if it's related to antialiasing. In f19, fonts look sharper. I know it's Cantarell specific because all other fonts look sharp, but only Cantarell looks fuzzy. If I change the hinting settings to "Slight", Cantarell looks sharp again but all other fonts look fuzzy.
Comment 4 sangu 2013-08-30 22:42:49 EDT
Please see attachment 785048 [details] in bug 995643

After updating to FreeType 2.5.0, this issue happens.
Comment 5 Akira TAGOH 2013-09-01 23:47:59 EDT

*** This bug has been marked as a duplicate of bug 995643 ***

Note You need to log in before you can comment on or make changes to this bug.