Bug 995705 - Install of Fedora FC 19 too dumbed down - will not allow software customization or install of multiple (GNOME+KDE) environments
Summary: Install of Fedora FC 19 too dumbed down - will not allow software customizati...
Status: CLOSED DUPLICATE of bug 875433
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-10 08:47 UTC by wwaustin
Modified: 2013-08-21 19:07 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-08-21 19:07:43 UTC


Attachments (Terms of Use)

Description wwaustin 2013-08-10 08:47:42 UTC
Description of problem:

I have a LARGE server used by multiple people (> 8 TB of disk, 16 GB ram, very fast machine.

I want to install FC19 and will be installing KDE, GNOME, and XFCE desktop environments.  The installer limits the user to ONE of these only.

Furthermore the is no more customization of the software to pick up many of the things I usually install on this machine (things on the disk but never offered in any screen I can find).

This version of the anaconda installer is far less intuitive and far more limiting than the ones used up through FC 17.  This bug will cost me a significant amount of additional time locating the things I want to install which SHOULD HAVE BEEN OPTIONS IN THE ORIGINAL INSTALL ITSELF.

Version-Release number of selected component (if applicable):

Fedora FC 19 (edora/linux/releases/19/Fedora/arch/iso/Fedora-19-x86_64-DVD.iso

How reproducible:
Happens every time.

Steps to Reproduce:
1.Put the dvd into the drive and reboot
2.Start the install
3.Try to select KDE + GNOME + XFCE at the same time

Actual results:
You get ONLY the last one clicked.

Expected results:
You should be able to install all 3 during the install.

Additional info:

I've been using RedHat and then Fedora since at least RH 5.0, and I have done well over 100 installs for myself and family, for friends, and for co-workers at the office).  There SHOULD be an "expert" option for the user to select any- and every- thing on the dvd if he really wants to.

NO, everybody won't choose that option.  But it should be there for those who want it.  The way it stands now, it reminds one of the Microsoft philosophy (we know better than you so we're going to limit your choices...).

Or as someone said on the user-request list, the person who "redesigned" this incarnation of the anaconda installer should be forced to use windows for 6 months. :-/

Comment 1 Steve Tyler 2013-08-10 21:31:08 UTC
(In reply to wwaustin from comment #0)
> Description of problem:
> 
> I have a LARGE server used by multiple people (> 8 TB of disk, 16 GB ram,
> very fast machine.
...
> Expected results:
> You should be able to install all 3 during the install.
...

A kickstart install is much more flexible than a GUI install:

Anaconda/Kickstart documentation wiki:
https://fedoraproject.org/wiki/Anaconda/Kickstart

F19 Installation Guide
Chapter 15. Kickstart Installations
http://docs.fedoraproject.org/en-US/Fedora/19/html/Installation_Guide/ch-kickstart2.html

Comment 2 Steve Tyler 2013-08-10 21:41:27 UTC
See Bug 856301, Comment 1:
Bug 856301 - Feature reqeust: Bring back package level customization

So, kickstart is definitely the way to go, especially given your high level of expertise.

Comment 3 Steve Tyler 2013-08-10 21:57:27 UTC
There are some example kickstart files attached here:
Bug 984709 - Anaconda kickstart install fails on package dosfstools

Comment 4 Steve Tyler 2013-08-10 22:01:02 UTC
A kickstart file that can be used to reinstall your system is here:
/root/anaconda-ks.cfg

Comment 5 Chris Lumens 2013-08-21 19:07:43 UTC

*** This bug has been marked as a duplicate of bug 875433 ***


Note You need to log in before you can comment on or make changes to this bug.