Bug 856301 - Feature reqeust: Bring back package level customization
Feature reqeust: Bring back package level customization
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 856454 866201 901340 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 13:08 EDT by Piruthiviraj Natarajan
Modified: 2013-04-12 15:38 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 15:24:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piruthiviraj Natarajan 2012-09-11 13:08:09 EDT
I installed RC2 alpha fedora 18. The new anaconda installer lacks the  individual package level customization as it was in Fedora 17 and previous versions.
The current customization in fedora 18 is vague and close to useless. 
Restoring the individual package level customization is an important feature of anaconda. 

Please bring back individual package level customization in Ananconda installer.
Comment 1 Chris Lumens 2012-09-11 15:24:00 EDT
Outside of kickstart, individual package selection will not be coming back.

First, package selection was always a lie.  You could request packages be included or excluded from installation, but in the end anaconda would end up doing what it needed to do anyway.  If you deselected a package that was required, you'd get it anyway.

Second, our package selection UI has been completely different from that on the rest of the system since we started using PackageKit.  This means the user had to learn two completely separate interfaces one of which was only useful for a very short time.

Third, anaconda is a poor place to do package-level selection.  There's not enough context for the user to decide what each package means and whether they want it or not, and no way to go about getting that information aside from having another computer present.  We've also learned over time that people really just want to get the install done with and move on to using the computer.

Fourth, package-level is really not how Fedora is organized anymore nor how we want to present it.  Sure there's a bazillion packages in the system, but for the most part this is an implementation detail.  We want to present Fedora as a complete, put-together base system to which you can add other groups to accomplish a task.  That's what the current UI presents.
Comment 2 Chris Lumens 2012-09-12 09:58:49 EDT
*** Bug 856454 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2012-10-15 10:51:03 EDT
*** Bug 866201 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2013-01-18 10:38:54 EST
*** Bug 901340 has been marked as a duplicate of this bug. ***
Comment 5 NavoneNew 2013-04-12 15:38:42 EDT
pure bullsh**; laziness; fantasy world.  you never take away. NEVER take away.  YOU cannot judge for others, you leave it as an option.  It is a theft of time.  There are people in countries, like where I write from, for whom internet connection is flaky.  They get a DVD, it has to have the option to CUSTOMIZE NOW and install ALL SOFTWARE.


First, package selection was always a lie.  You could request packages be included or excluded from installation, but in the end anaconda would end up doing what it needed to do anyway.  If you deselected a package that was required, you'd get it anyway.

YES BUT IF YOU SELECTED SOMETHING NOT INCLUDED IN THE DEFAULT YOU WOULD GET IT. SO IT WAS NOT A LIE.  YOU ARE RATIONALIZING. TO BE POLITE


Second, our package selection UI has been completely different from that on the rest of the system since we started using PackageKit.  This means the user had to learn two completely separate interfaces one of which was only useful for a very short time.

HMM... WE DON'T LIKE THE 2 WALLPAPERS SO WE WILL TEAR DOWN THE WALL ? MORE BS

Third, anaconda is a poor place to do package-level selection.  There's not enough context for the user to decide what each package means and whether they want it or not, and no way to go about getting that information aside from having another computer present.  We've also learned over time that people really just want to get the install done with and move on to using the computer

THAT IS NOT FOR YOU TO AUTOCRATICALLY DECIDE.  DID YOU TAKE A POLL ? MOST PEOPLE I KNOW LOVED THAT FEATURE

Fourth, package-level is really not how Fedora is organized anymore nor how we want to present it.  Sure there's a bazillion packages in the system, but for the most part this is an implementation detail.  We want to present Fedora as a complete, put-together base system to which you can add other groups to accomplish a task.  That's what the current UI presents.

WE DONT WANT WHAT YOU WANT ? WHAT THEN ?  CONTROL FREAK TIME ?

YOU NEVER TAKE AWAY

PUT IT BACK

Note You need to log in before you can comment on or make changes to this bug.