Bug 995788 - smc-fonts are not appearing in fc-list
smc-fonts are not appearing in fc-list
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: smc-fonts (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On: 978526
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-11 01:31 EDT by Anivar Aravind
Modified: 2013-08-27 03:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 03:19:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anivar Aravind 2013-08-11 01:31:43 EDT
Description of problem:
 
Just installed Fedora-Live-Desktop-x86_64-19-1.iso . While selecting language as malayalam on installation the font displayed is lohit-malayalam. Intented behaviour is displaying it with Meera font . (65-0-smc-meera.conf)

After Installation, Lohit-malayalam is the default font and 
fc-list :lang=ml displays only Lohit-malayalam .  Package smc-meera-fonts-5.0.1-5.fc19.noarch already installed by default but font is not displayed

/usr/share/fonts/lohit-malayalam/Lohit-Malayalam.ttf: Lohit Malayalam:style=Regular

Even after Installing following packages none of these fonts appear in applications

smc-anjalioldlipi-fonts       noarch      5.0.1-5.fc19       fedora       94 k
 smc-dyuthi-fonts              noarch      5.0.1-5.fc19       fedora       91 k
 smc-kalyani-fonts             noarch      5.0.1-5.fc19       fedora       50 k
 smc-rachana-fonts             noarch      5.0.1-5.fc19       fedora      297 k
 smc-raghumalayalam-fonts      noarch      5.0.1-5.fc19       fedora       37 k
 smc-suruma-fonts              noarch      5.0.1-5.fc19       fedora       87 k

fc-list :lang=ml returns with Only lohit-malayalam


Version-Release number of selected component (if applicable):
5.0.1-5.fc19

How reproducible:




Steps to Reproduce:
1.Try Installaion from Fedora-Live-Desktop-x86_64-19-1.iso with malayalam as language 
2.fc-list :lang=ml
3.sudo yum install smc-*  and check the font availability via fc-list :lang=ml

Actual results:

Only Lohit-malayalam is listed as malayalam font

Expected results:

All installed malayalam fonts will be diaplayed and meera  will be the default font

Additional info:
Comment 1 Pravin Satpute 2013-08-12 02:50:57 EDT
Hi Anivar,

   Unfortunately this got detected in very late stage of release cycle and release engineering included lohit-malayalam as a add on fonts due to lack of time.  https://bugzilla.redhat.com/show_bug.cgi?id=977764

   We recently build the live cd from development branch and smc-meera appears properly there now. 

  For present issues, you just need to run "$fc-cache -r" and it will fix the issues.
Comment 2 Pravin Satpute 2013-08-12 02:53:06 EDT
I think ideal solution to this bug will be providing alternate F19 Live iso with smc-meera appearing properly.

Parag what do you think?
Comment 3 Parag Nemade 2013-08-12 03:05:20 EDT
We can't fix issues in Live GA images because there are no updates to Live images. If there is any issues in actual installation then we can look into that issue.
Comment 4 Pravin Satpute 2013-08-21 07:02:44 EDT
hmm agree with you. This issues get resolved if someone run "$fc-cache -r"  after installing.
Comment 5 Pravin Satpute 2013-08-27 03:19:23 EDT
Tested with F20 Tc1 Meera appears properly now. http://alt.fedoraproject.org/pub/alt/stage/20-Alpha-TC1/Live/x86_64/Fedora-Live-Desktop-x86_64-20-Alpha-TC1-1.iso  

As discussed above cant update official live cd now. Closing this one.

Note You need to log in before you can comment on or make changes to this bug.