Bug 995803 - [abrt] WARNING: at fs/btrfs/super.c:254 __btrfs_abort_transaction+0xd9/0xf0 [btrfs]()
[abrt] WARNING: at fs/btrfs/super.c:254 __btrfs_abort_transaction+0xd9/0xf0 [...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fedora-kernel-btrfs
Fedora Extras Quality Assurance
abrt_hash:25a300f9806c483a4a202220fa1...
:
: 995885 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-11 05:19 EDT by klaus
Modified: 2013-09-23 16:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 16:19:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (68.64 KB, text/plain)
2013-08-11 05:19 EDT, klaus
no flags Details

  None (edit)
Description klaus 2013-08-11 05:19:12 EDT
Description of problem:
tried to mount an unrecognized partition on external harddisk. When plugging in usb cable got kerenel error report 

Additional info:
reporter:       libreport-2.1.6
WARNING: at fs/btrfs/super.c:254 __btrfs_abort_transaction+0xd9/0xf0 [btrfs]()
Modules linked in: xfs fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack bnep nf_conntrack bluetooth ebtable_filter rfkill ebtables ip6table_filter ip6_tables coretemp snd_usb_audio snd_usbmidi_lib kvm_intel kvm snd_rawmidi snd_hda_codec_hdmi crc32_pclmul snd_hda_codec_via crc32c_intel ppdev iTCO_wdt snd_hda_intel gspca_zc3xx iTCO_vendor_support gspca_main videodev snd_hda_codec snd_hwdep media snd_seq snd_seq_device snd_pcm microcode snd_page_alloc snd_timer parport_pc snd soundcore alx i2c_i801 of_i2c mei_me mdio mei lpc_ich parport uinput btrfs libcrc32c xor zlib_deflate usb_storage raid6_pq i915 i2c_algo_bit drm_kms_helper drm pata_sil680 i2c_core video
CPU: 1 PID: 2248 Comm: umount Not tainted 3.10.5-201.fc19.i686 #1
Hardware name: Gigabyte Technology Co., Ltd. To be filled by O.E.M./Z77M-D3H, BIOS F12 08/21/2012
 f31bbdf0 f31bbdf0 f31bbdb8 c0967bdf f31bbde0 c043d6ae f8bce9d0 f31bbe0c
 000000fe f8b2f899 f8b2f899 f05cd000 fffffffb 00000000 f31bbdf8 c043d703
 00000009 f31bbdf0 f8bce9d0 f31bbe0c f31bbe2c f8b2f899 f8bcc1ca 000000fe
Call Trace:
 [<c0967bdf>] dump_stack+0x16/0x18
 [<c043d6ae>] warn_slowpath_common+0x5e/0x80
 [<f8b2f899>] ? __btrfs_abort_transaction+0xd9/0xf0 [btrfs]
 [<f8b2f899>] ? __btrfs_abort_transaction+0xd9/0xf0 [btrfs]
 [<c043d703>] warn_slowpath_fmt+0x33/0x40
 [<f8b2f899>] __btrfs_abort_transaction+0xd9/0xf0 [btrfs]
 [<f8b5893d>] btrfs_commit_transaction+0x7bd/0xc40 [btrfs]
 [<c045db60>] ? wake_up_bit+0x20/0x20
 [<c045db60>] ? wake_up_bit+0x20/0x20
 [<f8b538fc>] btrfs_commit_super+0x7c/0xf0 [btrfs]
 [<f8b6bbcd>] ? btrfs_cleanup_defrag_inodes+0x2d/0x90 [btrfs]
 [<f8b53aff>] close_ctree+0x18f/0x230 [btrfs]
 [<c05578d1>] ? dispose_list+0x31/0x40
 [<c055820f>] ? evict_inodes+0x8f/0xc0
 [<f8b2ca36>] btrfs_put_super+0x16/0x20 [btrfs]
 [<c054389b>] generic_shutdown_super+0x4b/0xc0
 [<c0543a91>] kill_anon_super+0x11/0x20
 [<f8b2e604>] btrfs_kill_super+0x14/0x80 [btrfs]
 [<c0543e03>] deactivate_locked_super+0x33/0x50
 [<c0543e5a>] deactivate_super+0x3a/0x60
 [<c055b356>] mntput_no_expire+0xa6/0x100
 [<c055bef3>] SyS_umount+0x83/0x330
 [<c04acff6>] ? __audit_syscall_exit+0x1c6/0x260
 [<c09745cd>] sysenter_do_call+0x12/0x28
Comment 1 klaus 2013-08-11 05:19:19 EDT
Created attachment 785363 [details]
File: dmesg
Comment 2 Josh Boyer 2013-08-15 09:44:33 EDT
*** Bug 995885 has been marked as a duplicate of this bug. ***
Comment 3 Josh Boyer 2013-09-18 16:50:46 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 4 Josef Bacik 2013-09-23 16:19:41 EDT
Transaction aborts happen when you have IO errors in critical areas, which is the case for this abort, you had io errors on your device while we were trying to write out our super, this is completely normal.

Note You need to log in before you can comment on or make changes to this bug.