Bug 995932 - Syntax Highlighting not working when Language and Module names differ
Syntax Highlighting not working when Language and Module names differ
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.1
Unspecified Unspecified
urgent Severity high
: 3.2
: ---
Assigned To: Jeff Fearn
tools-bugs
:
: 997213 1004027 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-11 23:43 EDT by Jacquelynn East
Modified: 2014-07-13 11:28 EDT (History)
8 users (show)

See Also:
Fixed In Version: 3.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 02:20:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacquelynn East 2013-08-11 23:43:38 EDT
Description of problem:
In trying to build the Developer Guide, it fails and I get the error 

undefined language: Cplusplus at /usr/share/perl5/vendor_perl/Syntax/Highlight/Engine/Kate.pm line 638.
cannot create plugin for language 'Cplusplus'

Performing a grep on "Cplusplus" reveals nothing, but "language="C++"" shows it being used in things like

<programlisting language="C++"><xi:include parse="text" href="extras/fruit/fruit2.cc" xmlns:xi="http://www.w3.org/2001/XInclude" /></programlisting>

The book was last built approximately 6 months ago and this error was not present then. 

Version-Release number of selected component (if applicable):
3.1

How reproducible:
Every time as far as I can gather. Jaromir also had the same error on the User Guide.

Steps to Reproduce:
1. Add the above language tag to a doc
2. Attempt to brew with publican.
3. Enjoy the errors!

Actual results:
Build failed

Expected results:
Build succeeds

Additional info:
Comment 3 HSS Product Manager 2013-08-15 23:47:37 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 4 Stephen Gordon 2013-08-18 20:59:30 EDT
*** Bug 997213 has been marked as a duplicate of this bug. ***
Comment 5 Stephen Gordon 2013-08-18 21:00:42 EDT
Marked Bug # 997213 as a dupe because in a similar fashion it appears "INI Files" was accepted as a valid value in 3.1.5 but isn't in 3.2.0 (based on Kate.pm it still should be though).
Comment 6 Jeff Fearn 2013-08-18 21:43:15 EDT
Bug was in using Module name as language name, that only works if they match. e.g. XML is the language and the module, so that works.

To ssh://git.fedorahosted.org/git/publican.git
   42f4d93..4980426  HEAD -> devel
Comment 9 Misha H. Ali 2013-08-20 00:02:00 EDT
Checked with a local installation. Builds fine and the C++/Cplusplus parts looks fine.
Comment 10 Ruediger Landmann 2013-09-03 20:22:02 EDT
*** Bug 1004027 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.