Bug 997213 - programlisting language value of "INI_Files" / "INI Files" (possibly others) unrecognized.
programlisting language value of "INI_Files" / "INI Files" (possibly others) ...
Status: CLOSED DUPLICATE of bug 995932
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 20:23 EDT by Stephen Gordon
Modified: 2013-08-18 20:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-18 20:59:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-08-14 20:23:21 EDT
Description of problem:

I suspect this may be an issue with Syntax-Highlight-Engine-Kate but I want to get Jeff's input before I head upstream with it. When attempting to build a book with a programlisting that has language set to "INI_Files" I get this output:

undefined language: INI_Files at /usr/share/perl5/vendor_perl/Syntax/Highlight/Engine/Kate.pm line 634.
LibXSLT: error coming back from perl-dispatcher in pm file. 
	'INI_Files' is not a valid language for highlighting. Language names are case sensitive.

Looking in Kate.pm I can see this entry in the syntaxes construct:

'INI Files' => 'INI_Files'

Trying with the space ("INI Files") didn't really work out either, though it does appear to get converted to "INI_Files" as you might expect:

undefined language: INI_Files at /usr/share/perl5/vendor_perl/Syntax/Highlight/Engine/Kate.pm line 638.
cannot create plugin for language 'INI_Files'
Can't locate Syntax/Highlight/Engine/Kate/.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 149) line 1.
BEGIN failed--compilation aborted at (eval 149) line 1.

  STACK IS EMPTY: PANIC
 at /usr/share/perl5/vendor_perl/Syntax/Highlight/Engine/Kate/Template.pm line 463.
	Syntax::Highlight::Engine::Kate::Template::logwarning('Syntax::Highlight::Engine::Kate=HASH(0x3a20cd8)', 'cannot create plugin for language \'INI_Files\'\x{a}Can\'t locate...') called at /usr/share/perl5/vendor_perl/Syntax/Highlight/Engine/Kate/Template.pm line 509
	Syntax::Highlight::Engine::Kate::Template::pluginGet('Syntax::Highlight::Engine::Kate=HASH(0x3a20cd8)', 'INI_Files') called at /usr/share/perl5/vendor_perl/Syntax/Highlight/Engine/Kate.pm line 652
	Syntax::Highlight::Engine::Kate::reset('Syntax::Highlight::Engine::Kate=HASH(0x3a20cd8)') called at /usr/share/perl5/vendor_perl/Syntax/Highlight/Engine/Kate.pm line 581
	Syntax::Highlight::Engine::Kate::language('Syntax::Highlight::Engine::Kate=HASH(0x3a20cd8)', 'INI_Files') called at /usr/share/perl5/vendor_perl/Publican/Builder.pm line 2430
	Publican::Builder::highlight('XML::LibXML::NodeList=ARRAY(0x3a211b8)', 'XML::LibXML::NodeList=ARRAY(0x3be5660)') called at /usr/lib64/perl5/vendor_perl/XML/LibXSLT.pm line 81
	XML::LibXSLT::perl_dispatcher('CODE(0x3e8a5f0)', 'XML::LibXML::Document=SCALAR(0x3b47e08)', 'XML::LibXML::NodeList', 1, 'XML::LibXML::Document=SCALAR(0x3b55fd8)', 'XML::LibXML::NodeList', 1, 'XML::LibXML::Document=SCALAR(0x3bcfc60)') called at /usr/lib64/perl5/vendor_perl/XML/LibXSLT.pm line 467
	eval {...} called at /usr/lib64/perl5/vendor_perl/XML/LibXSLT.pm line 467
	eval {...} called at /usr/lib64/perl5/vendor_perl/XML/LibXSLT.pm line 467
	XML::LibXSLT::StylesheetWrapper::transform('XML::LibXSLT::StylesheetWrapper=HASH(0x3b40ff8)', 'XML::LibXML::Document=SCALAR(0x3bf3e90)', 'toc.section.depth', 2, 'generate.section.toc.level', 0, 'l10n.gentext.language', '\'en-US\'', 'brand', ...) called at /usr/share/perl5/vendor_perl/Publican/Builder.pm line 1557
	Publican::Builder::transform('Publican::Builder=HASH(0x3c34fa8)', 'HASH(0x3c42950)') called at /usr/share/perl5/vendor_perl/Publican/Builder.pm line 244
	Publican::Builder::build('Publican::Builder=HASH(0x3c34fa8)', 'HASH(0x3c34cf0)') called at /usr/bin/publican line 936
LibXSLT: error coming back from perl-dispatcher in pm file. Can't call method "basecontext" on an undefined value at /usr/share/perl5/vendor_perl/Syntax/Highlight/Engine/Kate.pm line 653.

TL;DR; It seems that the use of the syntax highlighting for INI, and possible other multi-word language values, is difficult if not impossible to trigger.

Version-Release number of selected component (if applicable):

publican-3.2.0.fc18
Comment 2 Stephen Gordon 2013-08-18 20:59:30 EDT

*** This bug has been marked as a duplicate of bug 995932 ***

Note You need to log in before you can comment on or make changes to this bug.