Bug 996270 - pci_hp_register failed and reset high-speed USB device using ehci-pci
pci_hp_register failed and reset high-speed USB device using ehci-pci
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 15:45 EDT by Enrique V. Bonet Esteban
Modified: 2013-11-27 11:37 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 11:37:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrique V. Bonet Esteban 2013-08-12 15:45:29 EDT
Description of problem:

Today, I upgrade the kernel from 3.9.11-200 to 3.10.4-100 in a Asus A52F
and I found two problems:

1- When the system boot, appear the message: "pciehp: pci_hp_register failed
with error -16".

This bug is similar to Fedora 19 963991 bug.

2- When I connect a Toshiba USB 3.0 external disk, the system return the
message (in /var/log/messages):

"reset high-speed USB device number 8 using ehci-pci" (obviously, the 8 is in
this case).

And the external USB don't appear in /dev/sdb for example, and it is not
mounted. The message is repeated every 30 seconds.

I execute the lsusb command and found the external USB disk:

$lsusb
...
Bus 002 Device 010: ID 0480:a006 Toshiba America Info. Systems, Inc.
$

This bug is similar to Fedora 19 994672 bug.

Version-Release number of selected component (if applicable):

Fedora 18 kernel 3.10.4.100

How reproducible:

Update the kernel from 3.9.11-200 to 3.10.4-100 in a ASUS A52F (sorry, I
am on holidays and I can not test it in other hardware).

Steps to Reproduce:
1. Execute the command yum upgrade kernel in a Fedora 18 system.
2. Reboot the system with the new kernel.
3. The system write the message "pciehp: pci_hp_register failed with error -16",
but the system boot.
4. When boot, connect a USB 3.0 disk in the computer, the system don't mount
the disk.

Actual results:

The external USB 3.0 disk is not mounted.

Expected results:

The external USB 3.0 disk is mounted.

Additional info:

I think that the second bug is caused by the first bug, but I am not a kernel
expert.
Comment 1 Enrique V. Bonet Esteban 2013-08-14 05:57:55 EDT
Today, I update a PC with Gigabyte P35-DS3P motherboard. Although the message 
"pciehp: pci_hp_register..." don't appear, the USB 3.0 external disk is not
mounted and the message "reset high..." appear in /var/log/message.
Comment 2 Josh Boyer 2013-08-15 10:11:23 EDT
The USB issue is being tracked by 989539
Comment 3 Enrique V. Bonet Esteban 2013-08-15 10:35:17 EDT
The new kernel 3.10.6-100 don't solved the problems. About the bug 989539, it is
for Fedora 19 kernel. I suppose that the solution code is similar, but the Fedora
version is distinct. Anyway, I look the 989539 bug for the USB issue problem.

Thanks Josh.
Comment 4 Josh Boyer 2013-08-15 10:42:35 EDT
The Fedora versions are different, but they're running the same base kernel.  It doesn't matter what version the bug is set to, it will get fixed in both.
Comment 5 Enrique V. Bonet Esteban 2013-08-17 04:31:46 EDT
The kernel 3.10.7-100, available in updates-testing, resolve the "reset
high-speed USB device number 8 using ehci-pci" and the USB 3.0 device is mounted.
Comment 6 Justin M. Forbes 2013-10-18 17:15:06 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 7 Enrique V. Bonet Esteban 2013-10-19 04:28:43 EDT
(In reply to Justin M. Forbes from comment #6)
> *********** MASS BUG UPDATE **************
> 
> We apologize for the inconvenience.  There is a large number of bugs to go
> through and several of them have gone stale.  Due to this, we are doing a
> mass bug update across all of the Fedora 18 kernel bugs.
> 
> Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel
> update (or newer) and let us know if you issue has been resolved or if it is
> still present with the newer kernel.
> 
> If you have moved on to Fedora 19, and are still experiencing this issue,
> please change the version to Fedora 19.
> 
> If you experience different issues, please open a new bug report for those.

Hi Justin,

All 3.10.X kernels don't solved the problem "pci_hp_register failed"
Comment 8 Enrique V. Bonet Esteban 2013-10-19 04:34:09 EDT
(In reply to Justin M. Forbes from comment #6)
> *********** MASS BUG UPDATE **************
> 
> We apologize for the inconvenience.  There is a large number of bugs to go
> through and several of them have gone stale.  Due to this, we are doing a
> mass bug update across all of the Fedora 18 kernel bugs.
> 
> Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel
> update (or newer) and let us know if you issue has been resolved or if it is
> still present with the newer kernel.
> 
> If you have moved on to Fedora 19, and are still experiencing this issue,
> please change the version to Fedora 19.
> 
> If you experience different issues, please open a new bug report for those.

Hi Justin,

All 3.10.X kernels don't solved the problem "pci_hp_register failed" but
the new 3.11.4 kernel ! fix the problem !. I think that the bug can be closed.

Thanks,

Enrique

Note You need to log in before you can comment on or make changes to this bug.