Bug 996630 - Designer: replace dependency SuperCSV with a better alternative
Designer: replace dependency SuperCSV with a better alternative
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Tihomir Surdilovic
Marek Baluch
:
Depends On:
Blocks: 989519
  Show dependency treegraph
 
Reported: 2013-08-13 10:44 EDT by Geoffrey De Smet
Modified: 2014-08-06 16:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoffrey De Smet 2013-08-13 10:44:30 EDT
The dependency org.supercsv:SuperCSV has bad maven metadata.
It generates a warning for every build:
  [WARNING] The POM for org.supercsv:SuperCSV:jar:1.52 is missing, no dependency information available

Therefore, it's too low quality to have it in our dependency tree - because it can cause maven issues and legal issues (no license specified).

There's only 1 class that needs it: StencilSetExtensionGeneratorServlet.java in designer.

Either upgrade it to a version that has decent maven metadata.
Or replace it with a Apache's commons-csv:
  http://commons.apache.org/proper/commons-csv/
Comment 2 Geoffrey De Smet 2013-08-14 03:48:56 EDT
Designer should also get rid of the jbpt dependency. It gives a similar warning as SuperCsv.
Comment 3 Geoffrey De Smet 2013-08-17 03:30:17 EDT
Apparently, SuperCSV doesn't exist in the central or jboss repository:
  https://repository.jboss.org/nexus/index.html#nexus-search;gav~org.supercsv~~~~

Really needs to be removed.
Comment 4 Tihomir Surdilovic 2013-08-17 11:03:07 EDT
SuperCSV dependency removed.
Comment 5 Marek Baluch 2013-09-04 07:49:31 EDT
Verified on ER2.

Note You need to log in before you can comment on or make changes to this bug.