Bug 996996 - Sometimes, when snapshot deletion failed ,the snapshot name presented as "UNKNOWN".
Sometimes, when snapshot deletion failed ,the snapshot name presented as "UNK...
Status: CLOSED DUPLICATE of bug 999821
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.0
Assigned To: Sergey Gotliv
Aharon Canan
storage
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 08:52 EDT by Leonid Natapov
Modified: 2016-02-10 15:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 07:15:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: Triaged+


Attachments (Terms of Use)
screen shot (246.96 KB, image/png)
2013-08-14 08:52 EDT, Leonid Natapov
no flags Details

  None (edit)
Description Leonid Natapov 2013-08-14 08:52:06 EDT
Created attachment 786529 [details]
screen shot

When snapshot deletion fails snapshot names that user sees in the Events Log presented as  "UNKNOWN" instead of real snapshot's name.

here is the engine log.
Reproduces not 100%.


2013-08-13 18:10:52,676 INFO  [org.ovirt.engine.core.vdsbroker.ResourceManager] (ServerService Thread Pool -- 39) VDS 07e08b6b-3c94-4793-96e9-3605a1f99dfc was added to the Resource Manager
2013-08-13 18:10:52,676 INFO  [org.ovirt.engine.core.vdsbroker.VdsManager] (ServerService Thread Pool -- 39) Entered VdsManager constructor
2013-08-13 18:10:52,776 INFO  [org.ovirt.engine.core.vdsbroker.VdsManager] (ServerService Thread Pool -- 39) Initialize vdsBroker (10.35.102.54,54,321)
2013-08-13 18:10:52,826 INFO  [org.ovirt.engine.core.vdsbroker.ResourceManager] (ServerService Thread Pool -- 39) VDS 08044c69-ed30-4f19-a749-a4046eb1e921 was added to the Resource Manager
2013-08-13 18:10:52,911 INFO  [org.ovirt.engine.core.vdsbroker.ResourceManager] (ServerService Thread Pool -- 39) Finished initializing ResourceManager
2013-08-13 18:10:52,954 INFO  [org.ovirt.engine.core.bll.OvfDataUpdater] (ServerService Thread Pool -- 39) Initialization of OvfDataUpdater completed successfully.
2013-08-13 18:10:53,122 INFO  [org.ovirt.engine.core.bll.scheduling.SchedulingManager] (ServerService Thread Pool -- 39) Start scheduling to enable vds load balancer
2013-08-13 18:10:53,123 INFO  [org.ovirt.engine.core.bll.scheduling.SchedulingManager] (ServerService Thread Pool -- 39) Finished scheduling to enable vds load balancer
2013-08-13 18:10:53,176 INFO  [org.ovirt.engine.core.bll.InitBackendServicesOnStartupBean] (ServerService Thread Pool -- 39) Init VM custom properties utilities
2013-08-13 18:10:53,176 INFO  [org.ovirt.engine.core.bll.InitBackendServicesOnStartupBean] (ServerService Thread Pool -- 39) Init device custom properties utilities
2013-08-13 18:10:53,212 INFO  [org.ovirt.engine.core.bll.network.MacPoolManager] (pool-5-thread-13) Start initializing MacPoolManager
2013-08-13 18:10:53,252 INFO  [org.ovirt.engine.core.bll.network.MacPoolManager] (pool-5-thread-13) Finished initializing MacPoolManager
2013-08-13 18:10:53,348 INFO  [org.ovirt.engine.core.bll.LogoutUserCommand] (ajp-/127.0.0.1:8702-4) Running command: LogoutUserCommand internal: false.
2013-08-13 18:10:53,437 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-5-thread-8) Correlation ID: 2f199b81, Call Stack: null, Custom Event ID: -1, Message: Failed to delete snapshot '1' for VM 'leonid
'.
2013-08-13 18:10:53,438 INFO  [org.ovirt.engine.core.bll.CommandAsyncTask] (pool-5-thread-8) CommandAsyncTask::HandleEndActionResult [within thread]: EndAction for action type RemoveSnapshot completed, handling the result.
2013-08-13 18:10:53,438 INFO  [org.ovirt.engine.core.bll.CommandAsyncTask] (pool-5-thread-8) CommandAsyncTask::HandleEndActionResult [within thread]: EndAction for action type RemoveSnapshot succeeded, clearing tasks.
2013-08-13 18:10:53,442 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-5-thread-12) Correlation ID: 7172115f, Call Stack: null, Custom Event ID: -1, Message: Failed to delete snapshot '1' for VM 'leoni
d'.
2013-08-13 18:10:53,442 INFO  [org.ovirt.engine.core.bll.CommandAsyncTask] (pool-5-thread-12) CommandAsyncTask::HandleEndActionResult [within thread]: EndAction for action type RemoveSnapshot completed, handling the result.
2013-08-13 18:10:53,443 INFO  [org.ovirt.engine.core.bll.CommandAsyncTask] (pool-5-thread-12) CommandAsyncTask::HandleEndActionResult [within thread]: EndAction for action type RemoveSnapshot succeeded, clearing tasks.
2013-08-13 18:10:53,448 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-5-thread-10) Correlation ID: 44672d1d, Call Stack: null, Custom Event ID: -1, Message: Failed to delete snapshot '<UNKNOWN>' for V
M 'leonid1'.
2013-08-13 18:10:53,448 INFO  [org.ovirt.engine.core.bll.CommandAsyncTask] (pool-5-thread-10) CommandAsyncTask::HandleEndActionResult [within thread]: EndAction for action type RemoveSnapshot completed, handling the result.
2013-08-13 18:10:53,448 INFO  [org.ovirt.engine.core.bll.CommandAsyncTask] (pool-5-thread-10) CommandAsyncTask::HandleEndActionResult [within thread]: EndAction for action type RemoveSnapshot succeeded, clearing tasks.
2013-08-13 18:10:53,450 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-5-thread-9) Correlation ID: 5d29391b, Call Stack: null, Custom Event ID: -1, Message: Failed to delete snapshot '<UNKNOWN>' for VM
 'leonid1'.



how to reproduce:
1.Create VM with disks.
2.Create snapshot.
2.Delete snapshot. Make the deletion fail. (restart engine while deleting snapshot).

Screen shot attached.
Comment 4 Leonid Natapov 2013-08-15 11:15:08 EDT
yes. audit log.
Comment 6 Sergey Gotliv 2013-08-22 07:15:07 EDT

*** This bug has been marked as a duplicate of bug 999821 ***

Note You need to log in before you can comment on or make changes to this bug.