Bug 999821 - Sometimes snapshot deletion fails because of engine restart during the deletion process.
Sometimes snapshot deletion fails because of engine restart during the deleti...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.5.0
Assigned To: Liron Aravot
storage
: Triaged
: 996996 (view as bug list)
Depends On: 999896
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 04:23 EDT by Leonid Natapov
Modified: 2016-02-10 14:20 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-16 07:43:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (48.00 KB, application/x-gzip)
2013-08-22 04:29 EDT, Sergey Gotliv
no flags Details
log2 (120.75 KB, application/x-gzip)
2013-08-22 04:30 EDT, Sergey Gotliv
no flags Details

  None (edit)
Description Leonid Natapov 2013-08-22 04:23:07 EDT
Description of problem:

When snapshot deletion fails because engine was restarted in the middle of deletion process the task never stops running. Getting exceptions in engine and  snapshot names that user sees in the Events Log presented as  "UNKNOWN" 

here is the engine log.
It's a race ,reproduces not 100%.
Version-Release number of selected component (if applicable):


How reproducible:

how to reproduce:
1.Create VM with disks.
2.Create snapshot.
2.Delete snapshot. Make the deletion fail. (restart engine while deleting snapshot).

logs attached.
Comment 1 Sergey Gotliv 2013-08-22 04:29:10 EDT
Created attachment 789084 [details]
log
Comment 2 Sergey Gotliv 2013-08-22 04:30:03 EDT
Created attachment 789085 [details]
log2
Comment 8 Sergey Gotliv 2013-08-22 07:15:07 EDT
*** Bug 996996 has been marked as a duplicate of this bug. ***
Comment 12 Liron Aravot 2014-06-16 07:43:32 EDT
There were multiple fixes and changes on those areas since this bug has been opened.
I tested the scenario in log (1) again (restarted the engine after the task polling has started and the flow ended succeslly.

Closing as WORKSFORME at the moment.

Note You need to log in before you can comment on or make changes to this bug.