Bug 997411 - wrong value in repoid when uninstalling using pulp-admin
Summary: wrong value in repoid when uninstalling using pulp-admin
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: consumers
Version: 2.2 Beta
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: Preethi Thomas
URL:
Whiteboard:
: 843848 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-15 13:00 UTC by Preethi Thomas
Modified: 2015-02-28 21:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 21:57:54 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 365 0 None None None Never

Description Preethi Thomas 2013-08-15 13:00:35 UTC
Description of problem:

If you use pulp-admin to unistall, the repoid in the report has the value as installed

Version-Release number of selected component (if applicable):

[root@hp-dl380pgen8-02-vm-16 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.25.beta.fc19.noarch
[root@hp-dl380pgen8-02-vm-16 ~]# 

How reproducible:


Steps to Reproduce:
[root@hp-dl380pgen8-02-vm-16 ~]# pulp-admin rpm consumer package uninstall run --consumer-id consumer1 --name zsh
Uninstall task created with id [ 97d1c884-6e74-4c88-a0ce-cb7291edb9d0 ]

This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ OK ]
Running Test Transaction                [ OK ]
Running Transaction                     [ OK ]

Uninstall Completed

+----------------------------------------------------------------------+
                              Uninstalled
+----------------------------------------------------------------------+

Name:    zsh
Version: 4.3.10
Arch:    x86_64
Repoid:  installed



[root@hp-dl380pgen8-02-vm-16 ~]# 


Actual results:


Expected results:


Additional info:

Comment 1 Sayli Karmarkar 2013-08-21 15:55:31 UTC
Remove repo id from the report.

Comment 2 Michael Hrivnak 2013-09-04 21:19:22 UTC
*** Bug 843848 has been marked as a duplicate of this bug. ***

Comment 3 Brian Bouterse 2015-02-28 21:57:54 UTC
Moved to https://pulp.plan.io/issues/365


Note You need to log in before you can comment on or make changes to this bug.