Bug 997418 - allow users to download Windows virt-viewer manually (avoid ActiveX plugin)
allow users to download Windows virt-viewer manually (avoid ActiveX plugin)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity high
: ---
: 3.4.0
Assigned To: Frantisek Kobzik
Jiri Belka
virt
: ZStream
Depends On: 978141 1010211
Blocks: 1061172 1064852 rhev3.4beta 1142926
  Show dependency treegraph
 
Reported: 2013-08-15 09:19 EDT by Michal Skrivanek
Modified: 2014-09-18 08:24 EDT (History)
15 users (show)

See Also:
Fixed In Version: av2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1061172 1064852 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18596 None None None Never
oVirt gerrit 19553 None None None Never
oVirt gerrit 19722 None None None Never
oVirt gerrit 24003 None None None Never
oVirt gerrit 24010 None None None Never

  None (edit)
Description Michal Skrivanek 2013-08-15 09:19:43 EDT
In order to be able to use MIME console launch we need to allow Windows users to download and install virt-viewer (and usb-clerk) via some other way than ActiveX plugin.

We should expose 64-bit version
/usr/share/spice/usbclerk-x64-0.0.1.1.msi
/usr/share/spice/virt-viewer-x64-0.5.6.msi

and 32bit versions:
/usr/share/spice/usbclerk-x86-0.0.1.1.msi
/usr/share/spice/virt-viewer-x86-0.5.6.msi

I was thinking the bottom of landing page would be appropriate
Comment 3 Jay Turner 2013-08-20 13:19:55 EDT
This needs to go through the exception process then as a late requirement.  Setting proposed exception.
Comment 6 Michal Skrivanek 2013-08-23 10:55:09 EDT
we are thinking of adding a page linked from Edit VM (maybe also the main landing page and other places) which would briefly describe the console access possibilities and provide downloadable resources
Comment 8 Frantisek Kobzik 2013-09-17 09:03:53 EDT
merged u/s: 17555a47cbcadfc1b44617181958bdd365fd8373
Comment 11 Alon Bar-Lev 2013-09-25 07:23:55 EDT
Please CC me for every usage of branding, so it won't be abused for something it was not designed to.

Thanks!
Comment 19 Michal Skrivanek 2013-10-10 08:58:50 EDT
patches merged, pending delivery of bug 1010211 and actual doc update
Comment 20 Marian Krcmarik 2013-11-02 12:34:49 EDT
(In reply to Michal Skrivanek from comment #19)
> patches merged, pending delivery of bug 1010211 and actual doc update

I've verified bug #1010211 on build spice-client-msi-3.3-5 which was tagged for rhevn inclusion so should be picked up with next is build, The msi files was renamed to names without version included. You are good to go.
Comment 22 Michal Skrivanek 2013-12-18 10:54:55 EST
doc page is dead end it seems, the links cannot be added due to dependency on customer portal.
Since we run out of time, for 3.3 we're going to remove the reference to upstream wiki and add a simple static page in english only in 3.3.z
Comment 26 Frantisek Kobzik 2014-02-27 08:57:35 EST
1064852 was set to modified, setting this bug to modified too since all prerequisities for having (localizable) console client resources are met.
Comment 27 Jiri Belka 2014-03-07 09:45:08 EST
ok, av2.1
Comment 28 Itamar Heim 2014-06-12 10:10:05 EDT
Closing as part of 3.4.0

Note You need to log in before you can comment on or make changes to this bug.