Bug 997535 - LUKSError: luks device not configured
LUKSError: luks device not configured
Status: CLOSED DUPLICATE of bug 983099
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:53145288d5e00ea4e8e92666fe1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 10:19 EDT by gev000
Modified: 2014-12-08 17:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 17:46:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (109.49 KB, text/plain)
2013-08-15 10:20 EDT, gev000
no flags Details
File: environ (525 bytes, text/plain)
2013-08-15 10:20 EDT, gev000
no flags Details
File: lsblk_output (5.46 KB, text/plain)
2013-08-15 10:20 EDT, gev000
no flags Details
File: messages (430.10 KB, text/plain)
2013-08-15 10:20 EDT, gev000
no flags Details
File: nmcli_dev_list (10.08 KB, text/plain)
2013-08-15 10:20 EDT, gev000
no flags Details
File: os_info (179 bytes, text/plain)
2013-08-15 10:20 EDT, gev000
no flags Details
File: program.log (200.25 KB, text/plain)
2013-08-15 10:20 EDT, gev000
no flags Details
File: ifcfg.log (1.83 KB, text/plain)
2013-08-15 10:20 EDT, gev000
no flags Details
File: packaging.log (54 bytes, text/plain)
2013-08-15 10:20 EDT, gev000
no flags Details
File: anaconda-tb (1.75 MB, application/octet-stream)
2013-08-15 10:20 EDT, gev000
no flags Details
File: storage.log (1.02 MB, application/octet-stream)
2013-08-15 10:21 EDT, gev000
no flags Details

  None (edit)
Description gev000 2013-08-15 10:19:58 EDT
Description of problem:
Trying to install fedora 19 from kde live x86_64 installation. Used custom partitioning.  I hit  "begin installation" and naconda  started the process but crashed complaining about luks configuration.  

Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/luks.py", line 163, in setup
    raise LUKSError("luks device not configured")
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 840, in setupParents
    _format.setup()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 703, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 714, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2607, in mountFilesystems
    device.setup()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1642, in mountFilesystems
    readOnly=readOnly, skipRoot=skipRoot)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 185, in turnOnFilesystems
    skipRoot=False)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 140, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
LUKSError: luks device not configured

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 gev000 2013-08-15 10:20:05 EDT
Created attachment 786947 [details]
File: anaconda.log
Comment 2 gev000 2013-08-15 10:20:09 EDT
Created attachment 786948 [details]
File: environ
Comment 3 gev000 2013-08-15 10:20:15 EDT
Created attachment 786949 [details]
File: lsblk_output
Comment 4 gev000 2013-08-15 10:20:21 EDT
Created attachment 786950 [details]
File: messages
Comment 5 gev000 2013-08-15 10:20:26 EDT
Created attachment 786951 [details]
File: nmcli_dev_list
Comment 6 gev000 2013-08-15 10:20:30 EDT
Created attachment 786952 [details]
File: os_info
Comment 7 gev000 2013-08-15 10:20:35 EDT
Created attachment 786953 [details]
File: program.log
Comment 8 gev000 2013-08-15 10:20:39 EDT
Created attachment 786954 [details]
File: ifcfg.log
Comment 9 gev000 2013-08-15 10:20:43 EDT
Created attachment 786955 [details]
File: packaging.log
Comment 10 gev000 2013-08-15 10:20:55 EDT
Created attachment 786956 [details]
File: anaconda-tb
Comment 11 gev000 2013-08-15 10:21:02 EDT
Created attachment 786957 [details]
File: storage.log
Comment 12 David Shea 2014-12-08 17:46:02 EST

*** This bug has been marked as a duplicate of bug 983099 ***

Note You need to log in before you can comment on or make changes to this bug.