Bug 997740 - Failed to auto-attach in subscription-manager-gui against SAM.
Failed to auto-attach in subscription-manager-gui against SAM.
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Tom McKay
SAM QE List
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-16 02:25 EDT by qianzhan
Modified: 2013-10-01 07:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:19:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'auto-attach with sm-gui' (1.84 MB, image/png)
2013-08-16 02:26 EDT, qianzhan
no flags Details
'Screenshot from 2013-08-23 13:14:24.png' (1.67 MB, image/png)
2013-08-23 01:21 EDT, qianzhan
no flags Details
'Screenshot from 2013-08-23 13:14:36.png' (2.09 MB, image/png)
2013-08-23 01:21 EDT, qianzhan
no flags Details

  None (edit)
Description qianzhan 2013-08-16 02:25:35 EDT
Description of problem:
Failed to auto-attach in subscription-manager-gui against SAM.

Version-Release number of selected component (if applicable):
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-7.el6sat.noarch
katello-cli-common-1.4.3-7.el6sat.noarch
katello-common-1.4.3-8.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
katello-headpin-1.4.3-8.el6sam_splice.noarch
katello-headpin-all-1.4.3-8.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
signo-katello-0.0.20-1.el6sat.noarch
candlepin-0.8.20-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.20-1.el6sam.noarch
candlepin-tomcat6-0.8.20-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch
subscription-manager-firstboot-1.8.20-1.el5
subscription-manager-gui-1.8.20-1.el5
subscription-manager-1.8.20-1.el5
python-rhsm: 1.8.16-1.el5

How reproducible:
always

Steps to Reproduce:
1. Register to SAM.
[root@dhcp-65-9 pki]# subscription-manager register
Username: admin
Password: 
The system has been registered with ID: 11d3b7cc-74b9-4fa5-accd-eabf03e422cb 

2. Open subscritpion-manager-gui, and click auto-attach button.

3. Check 'My Subscriptions' tab.

Actual results:
After step 2, a dialog pops with info "All installed products are covered by valid entitlements. No need to attach subscriptions at this time." See attachment 'auto-attach with sm-gui'
After step 3, there is no subscriptions displayed in 'My Subscriptions' tab.

Expected results:
After step 2, there should be subscriptions displayed in 'My Subscriptions' tab.

Additional info:
I can auto-attach in CLI.
katello-debug info is attached as 'katello-debug info'.
Comment 1 qianzhan 2013-08-16 02:26:25 EDT
Created attachment 787156 [details]
'auto-attach with sm-gui'
Comment 3 Carter Kozak 2013-08-16 10:27:05 EDT
Your system appears to be disconnected from the server.  The gui does not have any compliance info.
Comment 4 qianzhan 2013-08-19 01:29:43 EDT
(In reply to Carter Kozak from comment #3)
> Your system appears to be disconnected from the server.  The gui does not
> have any compliance info.

I have checked my system which is connected to the server well, because I can auto-attach in CLI. About the issue of the gui not having compliance info, I have filed another bug 994992 to track.
Comment 5 Tom McKay 2013-08-19 10:49:45 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: cab81f6e97653b1146914d7bd1baa24f30b1bfb5
      https://github.com/Katello/katello/commit/cab81f6e97653b1146914d7bd1baa24f30b1bfb5
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-08-16 (Fri, 16 Aug 2013)
Comment 7 qianzhan 2013-08-23 01:20:08 EDT
Verifying Version:

katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-8.el6sat.noarch
katello-cli-common-1.4.3-8.el6sat.noarch
katello-common-1.4.3-9.el6sam_splice.noarch
katello-configure-1.4.4-3.el6sat.noarch
katello-glue-candlepin-1.4.3-9.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-9.el6sam_splice.noarch
katello-headpin-1.4.3-9.el6sam_splice.noarch
katello-headpin-all-1.4.3-9.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
signo-katello-0.0.20-1.el6sat.noarch
candlepin-0.8.21-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.21-1.el6sam.noarch
candlepin-tomcat6-0.8.21-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch
subscription-manager: 1.8.20-1.el5
python-rhsm: 1.8.16-1.el5

1. Open GUI, register and auto-attach successfully.
2. Please see attachments 'Screenshot from 2013-08-23 13:14:24.png' and 'Screenshot from 2013-08-23 13:14:36.png' for details.

Marking the status to 'VERIFIED'
Comment 8 qianzhan 2013-08-23 01:21:07 EDT
Created attachment 789446 [details]
'Screenshot from 2013-08-23 13:14:24.png'
Comment 9 qianzhan 2013-08-23 01:21:45 EDT
Created attachment 789448 [details]
'Screenshot from 2013-08-23 13:14:36.png'
Comment 11 errata-xmlrpc 2013-10-01 07:19:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.