Bug 994992 - The status is unknown and the GUI is grey after subscribe a valid subscription against SAM
The status is unknown and the GUI is grey after subscribe a valid subscriptio...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Tom McKay
SAM QE List
:
: 998849 998879 999881 (view as bug list)
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-08 07:10 EDT by qianzhan
Modified: 2013-10-01 07:17 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:17:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'Screenshot-status.png' (166.69 KB, image/png)
2013-08-08 07:12 EDT, qianzhan
no flags Details
'Screenshot-status2.png' (167.38 KB, image/png)
2013-08-08 07:13 EDT, qianzhan
no flags Details
'Screenshot from 2013-08-23 12:56:11.png' (167.27 KB, image/png)
2013-08-23 01:09 EDT, qianzhan
no flags Details

  None (edit)
Description qianzhan 2013-08-08 07:10:30 EDT
Description of problem:
The status is unknown and the GUI is grey after subscribe a valid subscription against SAM

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-1.8.19-1.el5
subscription-manager-gui-1.8.19-1.el5
subscription-manager-1.8.19-1.el5
python-rhsm-1.8.16-1.el5
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-5.el6sat.noarch
katello-cli-common-1.4.3-5.el6sat.noarch
katello-common-1.4.3-6.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
katello-headpin-1.4.3-6.el6sam_splice.noarch
katello-headpin-all-1.4.3-6.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
signo-katello-0.0.10-2.el6sat.noarch
candlepin-0.8.19-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.19-1.el6sam.noarch
candlepin-tomcat6-0.8.19-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch

How reproducible:
always

Steps to Reproduce:
1.Register to SAM
[root@unused-65-221 ~]# subscription-manager register
Username: admin
Password: 
The system has been registered with ID: c17ad36c-0681-4524-b897-aabe57a3205f 

2.Auto subscribe
[root@unused-65-221 ~]# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Desktop
Status:       Unknown

3.Check the installed product and consumed subsciption
[root@unused-65-221 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Desktop
Product ID:     68
Version:        5.10 Beta
Arch:           i386
Status:         Unknown
Status Details: 
Starts:         07/25/2013
Ends:           07/24/2014

[root@unused-65-221 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Enterprise Linux Desktop (50 pack), Standard
Provides:          Red Hat Enterprise Linux Desktop
                   Red Hat Beta
SKU:               RH0823221
Contract:          10024928
Account:           5225762
Serial:            5298496907130049946
Pool ID:           8ac28cf1405ce5f301405cfcd30503e0
Active:            True
Quantity Used:     1
Service Level:     Standard
Service Type:      L1-L3
Status Details:    
Starts:            07/25/2013
Ends:              07/24/2014

4.Check the GUI
The status of 'My Installed Products' is 'unknown' and color is grey.
There is subscription which is auto-attached in 'My Subscriptions' tab and the color is grey.

Actual results:
As above

Expected results:
The status should be 'Subscribed' after subscribe a valid subscription, and the GUI should be green.

Additional info:
(1) The status is also 'unknown' if I specify a subscription to subscribe.
(2) Please check the GUI through 'Screenshot-status.png' and 'Screenshot-status2.png'
(3) I test this bug on stage candlepin and it's all right.
Comment 1 qianzhan 2013-08-08 07:12:44 EDT
Created attachment 784310 [details]
'Screenshot-status.png'
Comment 2 qianzhan 2013-08-08 07:13:16 EDT
Created attachment 784311 [details]
'Screenshot-status2.png'
Comment 3 Devan Goodwin 2013-08-12 13:21:40 EDT
Installed latest SAM 1.3 build SAM-1.3.0-RHEL-6-20130808.0 today, cannot reproduce. Registered a client, subscribed, and status is correct in both CLI and GUI:

(root@rhel6-dev ~) $ subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Employee Subscription
Provides:          Red Hat Enterprise Linux Load Balancer (for RHEL Server)
                   Red Hat Enterprise Linux Workstation
                   Red Hat Enterprise Linux Server
                   Red Hat Enterprise Linux High Availability (for RHEL Server)
                   Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
SKU:               SYS0395
Contract:          2595500
Account:           1212729
Serial:            4134247595218354661
Pool ID:           ff8080814073316d014073822a560032
Active:            True
Quantity Used:     1
Service Level:     None
Service Type:      None
Status Details:    
Starts:            10/11/2011
Ends:              01/01/2022


Moving to ON_QA.
Comment 5 Carter Kozak 2013-08-16 10:51:49 EDT
I get a 403 (forbidden) response from your server, but only when I try to get compliance.  I can't reproduce this on my end.

[ckozak@ckozak-desktop ~]$ curl -k -u admin:admin https://10.66.65.49:8443/candlepin/consumers/38c2750d-5e12-4942-a3ea-1aafe038c7e0/compliance

{"displayMessage":"Invalid credentials."}
Comment 7 Adrian Likins 2013-08-16 11:53:27 EDT
What is the correct username/password for registering to that sam server?
Comment 9 Tom McKay 2013-08-19 10:49:49 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: cab81f6e97653b1146914d7bd1baa24f30b1bfb5
      https://github.com/Katello/katello/commit/cab81f6e97653b1146914d7bd1baa24f30b1bfb5
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-08-16 (Fri, 16 Aug 2013)
Comment 11 Carter Kozak 2013-08-20 11:36:24 EDT
*** Bug 998879 has been marked as a duplicate of this bug. ***
Comment 12 Carter Kozak 2013-08-20 11:38:49 EDT
*** Bug 998849 has been marked as a duplicate of this bug. ***
Comment 13 Carter Kozak 2013-08-22 08:28:57 EDT
*** Bug 999881 has been marked as a duplicate of this bug. ***
Comment 14 qianzhan 2013-08-23 01:08:55 EDT
Verifying Version:

katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-8.el6sat.noarch
katello-cli-common-1.4.3-8.el6sat.noarch
katello-common-1.4.3-9.el6sam_splice.noarch
katello-configure-1.4.4-3.el6sat.noarch
katello-glue-candlepin-1.4.3-9.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-9.el6sam_splice.noarch
katello-headpin-1.4.3-9.el6sam_splice.noarch
katello-headpin-all-1.4.3-9.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
signo-katello-0.0.20-1.el6sat.noarch
candlepin-0.8.21-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.21-1.el6sam.noarch
candlepin-tomcat6-0.8.21-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch
subscription-manager: 1.8.20-1.el5
python-rhsm: 1.8.16-1.el5

[root@test1 ~]# subscription-manager register --auto-attach
Username: admin
Password: 
The system has been registered with ID: 41a745ca-e68b-4c58-be3d-eca242ff1fa3 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

[root@test1 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        5.10 Beta
Arch:           x86_64
Status:         Subscribed
Status Details: 
Starts:         07/25/2013
Ends:           07/24/2014

[root@test1 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Employee Subscription
Provides:          Red Hat Enterprise Linux Load Balancer (for RHEL Server)
                   Red Hat Enterprise Linux Workstation
                   Red Hat Enterprise Linux Server
                   Red Hat Enterprise Linux High Availability (for RHEL Server)
                   Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
SKU:               SYS0395
Contract:          None
Account:           5225762
Serial:            5166365771468073326
Pool ID:           8ac28d2340a922640140a925998000d1
Active:            True
Quantity Used:     1
Service Level:     None
Service Type:      None
Status Details:    
Starts:            07/25/2013
Ends:              07/24/2014

Please see attachment 'Screenshot from 2013-08-23 12:56:11.png' for GUI details

Marking status as 'VERIFIED'
Comment 15 qianzhan 2013-08-23 01:09:47 EDT
Created attachment 789445 [details]
'Screenshot from 2013-08-23 12:56:11.png'
Comment 17 errata-xmlrpc 2013-10-01 07:17:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.