Bug 997946 - environment-modules versions less than v3.2.10 are buggy
environment-modules versions less than v3.2.10 are buggy
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: environment-modules (Show other bugs)
el5
All All
unspecified Severity high
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 11:21 EDT by Fotis Georgatos
Modified: 2013-08-31 15:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: environment-modules-3.2.10-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 15:21:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 697906 None None None Never

  None (edit)
Description Fotis Georgatos 2013-08-16 11:21:23 EDT
Description of problem:
environment-modules releases less than v3.2.10 are buggy. 
There is a complicated issue rising up in relation to a Tcl buffer, which only pops up with many or long modules (to fill up the caching buffer).
Patch has been available for a year already and it is part of v3.2.10 release (Dec. 2012). At some point this has to become an .rpm package for RHEL (Fedora has it already for some time!)

Version-Release number of selected component (if applicable):
<3.2.10

How reproducible:
As described in:
http://sourceforge.net/mailarchive/forum.php?thread_name=AE3A94B6-2879-4859-B966-BD3CBABFFD4E%40ugent.be&forum_name=modules-interest
&
http://sourceforge.net/mailarchive/forum.php?forum_name=modules-interest&max_rows=25&style=nested&viewmonth=201208

Steps to Reproduce:
1. module load <a module with many dependencies>
2. module list (empty list)
3. 

Actual results:
(silent core dump occurs)

Expected results:
see the exact items loaded!

Additional info:
http://rpmfind.net/linux/RPM/fedora/devel/rawhide/x86_64/e/environment-modules-3.2.10-6.fc20.x86_64.html
Comment 1 Fedora Update System 2013-08-16 12:15:42 EDT
environment-modules-3.2.10-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/environment-modules-3.2.10-1.el5
Comment 2 Fedora Update System 2013-08-16 15:52:55 EDT
Package environment-modules-3.2.10-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing environment-modules-3.2.10-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11238/environment-modules-3.2.10-1.el5
then log in and leave karma (feedback).
Comment 3 Fotis Georgatos 2013-08-26 19:45:35 EDT
sorry but I have tried several times already to fill the form "Sign up for a Fedora account" and the captcha claims to be always wrong. I suspect the captcha is plainly broken.

If anybody reads this, please increase the karma here on my behalf:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11238/environment-modules-3.2.10-1.el5

tia,
Fotis
Comment 4 Fedora Update System 2013-08-31 15:21:30 EDT
environment-modules-3.2.10-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.