Bug 998056 - Brother HL-2040 printed left half of each page on left and right sides of the sheet
Brother HL-2040 printed left half of each page on left and right sides of the...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 17:48 EDT by Peter H. Jones
Modified: 2013-12-02 13:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-02 08:34:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
printer installer troubleshooter output (206.37 KB, text/plain)
2013-08-16 17:49 EDT, Peter H. Jones
no flags Details
print troubleshooter output (165.40 KB, text/plain)
2013-08-16 18:17 EDT, Peter H. Jones
no flags Details
troubleshoot output when printing incorrectly (197.69 KB, text/plain)
2013-09-09 17:26 EDT, Peter H. Jones
no flags Details
Troubleshoot logs when printing PDF from Evince (306.49 KB, text/plain)
2013-09-28 07:22 EDT, Milan Bouchet-Valat
no flags Details
troubleshoot with incorrect printing (180.45 KB, text/plain)
2013-10-10 09:13 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2013-08-16 17:48:20 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0
Build Identifier: 

HL-2040 prints left half of each page on left and right sides of the sheet.
When I use the Print Troubleshooter, (will attach output), my page printed OK.

Reproducible: Always

Steps to Reproduce:
1. Try to print a test page, or a normal file.
2.
3.
Actual Results:  
Content of left half of page is repeated on the right. I remember seeing that behaviour many years ago when the HL-2040 first appeared on the market.

Expected Results:  
Normal printing.

Got messages running system-config-printer:
"[root@localhost Desktop]# system-config-printer
cannot connect to the session bus: The connection is closed (g-io-error-quark, 18)
cannot connect to the session bus: The connection is closed (g-io-error-quark, 18)
cannot connect to the session bus: The connection is closed (g-io-error-quark, 18)
/usr/share/system-config-printer/system-config-printer.py:2056: GtkWarning: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.H2SL1W': No such file or directory
  gtk.main()
/usr/share/system-config-printer/system-config-printer.py:2056: GtkWarning: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory
  gtk.main()

/usr/share/system-config-printer/system-config-printer.py:2056: GtkWarning: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.ITSP1W': No such file or directory
  gtk.main()"
Comment 1 Peter H. Jones 2013-08-16 17:49:30 EDT
Created attachment 787463 [details]
printer installer troubleshooter output
Comment 2 Peter H. Jones 2013-08-16 18:17:49 EDT
Created attachment 787464 [details]
print troubleshooter output

Got the problem again, when printing an Adobe document was printed under the troubleshooter. However, if I print a test page, followed by my document, both are correct! Presumably, the test page causes a change in the printer settings.
Comment 3 Tim Waugh 2013-08-20 11:15:42 EDT
Missing Device ID reported in bug #999040, although it isn't the cause of this bug.
Comment 4 Tim Waugh 2013-08-20 11:17:35 EDT
Could you attach an example document that prints incorrectly please?

It would also be useful to try to capture the debug logs from when this document is actually printing incorrectly. You can use the printing troubleshooter to do that: when it says to print something, you can print as normal from another application. It should then show that job in the list, so you can just tick the checkbox for that job to say it's the one in question.
Comment 5 Peter H. Jones 2013-08-25 09:48:51 EDT
Thanks for your quick response. I'll be able to access the printer within a couple of weeks and provide the information.
Comment 6 Peter H. Jones 2013-09-09 17:26:21 EDT
Created attachment 795759 [details]
troubleshoot output when printing incorrectly

Tested the printer today. The printing is incorrect (right half is echo of left half).
Comment 7 Peter H. Jones 2013-09-15 11:08:30 EDT
Printer is still working fine on a F17 system. Is there a way to bring the drivers from that system to F18 ff?
Comment 8 Peter H. Jones 2013-09-16 17:42:51 EDT
Printed a typewriter-like document from gedit successfully.
Comment 9 Peter H. Jones 2013-09-17 21:18:31 EDT
Worked OK with a booking confirmation from booking.com. I selected Print while booking, then used Print-to-File in the printer selection menu. Problem seems to occur when printing PDF's from the Orleans Express bus company.
Comment 10 Milan Bouchet-Valat 2013-09-24 14:46:14 EDT
I'm also experiencing this bug since Fedora 18, and it's still present on Fedora 19. I have a HL-2030.

Printing from LibreOffice works fine, but printing from gedit or a PDF generated from gedit (via print to file) exhibits the same bug. What is the difference between these two apps? I thought both of them were passing PDF directly to CUPS...

Please just ask if you need any logs or testing.
Comment 11 Peter H. Jones 2013-09-27 05:24:05 EDT
Worked today, with a document of the type showing the problem, with foomatic-4.0.8-13.fc18.x86_64 .
Comment 12 Milan Bouchet-Valat 2013-09-28 07:22:55 EDT
Created attachment 804387 [details]
Troubleshoot logs when printing PDF from Evince

Please find attach the debug logs requested in comment #4. They correspond to a PDF document (containing only an image) that exhibited such a bug.

An interesting point is that the first time I tried printing this PDF (not shown in the logs), I got a different problem: only the first 5 cm of the page were actually printed, and the printer continued outputting blank pages until it ran out of paper.

Foomatic here is 4.0.9-3.fc19.x86_64.
Comment 13 Milan Bouchet-Valat 2013-09-28 07:29:10 EDT
Oh, and FWIW, Adobe Reader prints the same PDF (and others which suffer from the same problem) correctly.
Comment 14 Peter H. Jones 2013-10-10 09:13:50 EDT
Created attachment 810508 [details]
troubleshoot with incorrect printing

Got the problem again today.
Comment 15 Peter H. Jones 2013-10-10 09:17:22 EDT
"$ rpm -qa | grep foomatic" gives:
foomatic-db-filesystem-4.0-34.20121011.fc18.noarch
foomatic-db-4.0-34.20121011.fc18.noarch
foomatic-filters-4.0.8-13.fc18.x86_64
foomatic-db-ppds-4.0-34.20121011.fc18.noarch
foomatic-4.0.8-13.fc18.x86_64
Comment 16 Peter H. Jones 2013-10-10 09:47:59 EDT
Same document printed OK on another system:
# rpm -qa | grep foomatic
foomatic-db-4.0-34.20121011.fc18.noarch
foomatic-4.0.8-13.fc18.i686
foomatic-db-ppds-4.0-34.20121011.fc18.noarch
foomatic-filters-4.0.8-13.fc18.i686
foomatic-db-filesystem-4.0-34.20121011.fc18.noarch
Comment 17 Tim Waugh 2013-11-25 11:50:55 EST
Could you try using one of the other drivers to see if that makes a difference to the problem? e.g.:

Brother HL-2040 Foomatic/ljet4
Brother HL-2040 Foomatic/lj4dith
Brother HL-2040 Foomatic/hpijs-pcl5e
Comment 18 Milan Bouchet-Valat 2013-12-02 03:53:44 EST
Ah, it works with hpijs-pcl5e!

With hl1250 I get the same problem; with lj4dith the printer blinks but then stops and nothing is printed; with lj5gray the printer turns off when I try to print; with ljet4 I get a blank page. So definitely not a great support from all drivers... ;-)
Comment 19 Tim Waugh 2013-12-02 06:17:39 EST
Thanks. Just for the record, so we know which versions work and don't work, what does 'rpm -q ghostscript hpijs' say?

Needs fixing in foomatic I think.
Comment 20 Milan Bouchet-Valat 2013-12-02 08:21:33 EST
Thanks for taking care of this.

$ rpm -q ghostscript hpijs
ghostscript-9.10-4.fc19.x86_64
hpijs-3.13.9-2.fc19.x86_64
Comment 21 Tim Waugh 2013-12-02 08:34:51 EST
Reported upstream:
https://bugs.linuxfoundation.org/show_bug.cgi?id=1173
Comment 22 Peter H. Jones 2013-12-02 13:14:56 EST
Thanks to those who already responded to comment #17. The site producing the documents, http://www.orleansexpress.com , has changed its procedure. Instead of sending PDFs, there is now a button labeled "Imprimer vos billets" that goes directly to the printer.

I note a difference between Midori and Firefox. When I use Midori, I can get a page preview after clicking the above link, and I can save the file as a PDF instead of printing. In Firefox, after selecting the link, the page preview is grayed out.

I'll try the old PDFs to see if I still can still reproduce the problem. Then I plan to repeat the test when the upstream update becomes available in Fedora.
Comment 23 Milan Bouchet-Valat 2013-12-02 13:35:43 EST
Note that CLOSED UPSTREAM does not mean it's fixed upstream, just that it's been reported.

Note You need to log in before you can comment on or make changes to this bug.