Bug 999040 - Missing Device ID: Brother HL-2040
Missing Device ID: Brother HL-2040
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic-db (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: IEEE1284DeviceIDs
  Show dependency treegraph
 
Reported: 2013-08-20 11:08 EDT by Tim Waugh
Modified: 2013-09-11 10:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: foomatic-db-4.0-40.20130911.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 10:35:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2013-08-20 11:08:55 EDT
Description of problem:
The entry for "Brother HL-2040" is missing a device ID (got ID from bug #998056).

./check-device-ids.py "Brother HL-2040 series" "MFG:Brother;CMD:PJL,HBP;MDL:HL-2040 series;CLS:PRINTER;"
Installing relevant drivers using session service
Fetching driver list
└── Brother HL-2040 series (user-specified): MFG:Brother;MDL:HL-2040 series;CMD:PJL,HBP;
    ├── foomatic:Brother-HL-2060-Postscript.ppd [/usr/lib/cups/driver/foomatic]
    ├── foomatic:Brother-HL-2060-hl1250.ppd [/usr/lib/cups/driver/foomatic]
    ├── foomatic:Brother-HL-2060-pxlmono.ppd [/usr/lib/cups/driver/foomatic]
    ├── foomatic:Brother-HL-2060-ljet4.ppd [/usr/lib/cups/driver/foomatic]
    ├── foomatic:Brother-HL-2060-lj4dith.ppd [/usr/lib/cups/driver/foomatic]
    ├── foomatic:Brother-HL-2060-lj5gray.ppd [/usr/lib/cups/driver/foomatic]
    └── foomatic:Brother-HL-2060-hpijs-pcl5e.ppd [/usr/lib/cups/driver/foomatic]
        MISSING  foomatic:Brother-HL-2040-hl1250.ppd [/usr/lib/cups/driver/foomatic]
        MISSING  foomatic:Brother-HL-2040-ljet4.ppd [/usr/lib/cups/driver/foomatic]
        MISSING  foomatic:Brother-HL-2040-hpijs-pcl5e.ppd [/usr/lib/cups/driver/foomatic]
        MISSING  foomatic:Brother-HL-2040-lj4dith.ppd [/usr/lib/cups/driver/foomatic]

Version-Release number of selected component (if applicable):
foomatic-db-4.0-38.20130604.fc19.noarch
Comment 1 Jiri Popelka 2013-09-11 10:35:30 EDT
Fixed with foomatic-db-4.0-40.20130911.fc21

Note You need to log in before you can comment on or make changes to this bug.