Bug 998397 - Implement Send Side Scaling RSS extension
Implement Send Side Scaling RSS extension
Status: CLOSED DUPLICATE of bug 1096505
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: Dmitry Fleytman
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 04:29 EDT by Dmitry Fleytman
Modified: 2014-06-22 05:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-22 05:09:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Fleytman 2013-08-19 04:29:23 EDT
There is an RSS extension called "Send Side Scaling":

From http://technet.microsoft.com/en-us/library/hh997036.aspx:
Send Side Scaling: The RSS hash value is passed by the TCP/IP protocol to the network interface card in each packet on the egress path thus allowing for the send completions to be indicated on the same CPU. This enables better scaling on the send side.

While it is not a mandatory feature it may have positive performance impact.
Needs to be investigated and (probably) implemented.
Comment 4 Yan Vugenfirer 2014-06-22 05:09:29 EDT
Will be implemented as part of the multi-queue support in Windows driver.

*** This bug has been marked as a duplicate of bug 1096505 ***

Note You need to log in before you can comment on or make changes to this bug.