Bug 9984 - separate autofs executable and config files
separate autofs executable and config files
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-05 13:48 EST by sean
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-05 16:06:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2000-03-05 13:48:11 EST
autofs will not automatically check NIS for an auto.master map if there is
an auto.master file that already exists in /etc.

So, when I deploy a RH workstation that autofs mounts it's homedirectories
off of an NFS server it comes up in a basic way ready to log in (with NIS
already working, etc) except that autofs isn't seeing the NIS maps because
there is a sample auto.master file that gets installed.

it would be wonderful if that file could be renamed to auto.master.example
or put in a separate RPM that didn't have to be installed.  Then autofs
would "just work" on the first boot of the workstation.

(or, I guess another option would be to modify autofs such that it always
checks for an NIS-supplied auto.master map regardless of the existance of
an auto.master file)
Comment 1 Nalin Dahyabhai 2000-03-06 08:05:59 EST
This is fixed in Raw Hide, where autofs(18) starts after ypbind(17).

*** This bug has been marked as a duplicate of 9925 ***
Comment 2 Nalin Dahyabhai 2000-03-06 08:06:59 EST
Whoops, 9985 is the duplicate.
Comment 3 Nalin Dahyabhai 2000-03-06 09:07:59 EST
We generally don't split configuration files from the packages they go with,
because the defaults are correct for most cases.  The behavior you're seeing
is the result of a fix for an earlier bug report, where conflicting entries in
the file and NIS caused problems.  If you're deploying workstations using
kickstart, you can add:
rm -f /etc/auto.master
to your %post section, and that will solve your problem.
Comment 4 Nalin Dahyabhai 2000-04-05 16:06:59 EDT
I've just put autofs-3.1.4-6 into Raw Hide
(ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/), which
backs out the change that ignores NIS auto.master in favor
of merging the two.  Please let me know if switching to this
version solves the problem.
Comment 5 Nalin Dahyabhai 2000-06-10 17:25:16 EDT
I haven't heard anything in about six weeks, so I'm closing this bug out.

Note You need to log in before you can comment on or make changes to this bug.