Bug 9925 - autofs init.d script now broken for NIS auto.master
autofs init.d script now broken for NIS auto.master
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 9983 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-02 17:01 EST by Gilbert E. Detillieux
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-02 17:43:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilbert E. Detillieux 2000-03-02 17:01:08 EST
For some reason, the start/stop sequence numbers in the chkconfig comment
for the autofs init.d script changed from RH 6.1 to 6.2.  Unfortunately,
the new sequence (15) causes it to start before ypbind (17).  This is bad
if you want to read the NIS auto.master map.

Also (and I don't know if this second problem is a bug or a feature), the
old script used to run through /etc/auto.master followed by the NIS
auto.master map, with two separate "if" clauses.  Now, a single if/else
construct causes it to skip the NIS map if /etc/auto.master is found. This
may be closer to the Solaris automount behaviour, but the old way was
better, IMHO, especially since the stock /etc/auto.master is not
particularly useful as is.  (But I can live with this if it's an
intentional feature - I'll just have to take out /etc/auto.master to get
the NIS map instead.)

--- /etc/rc.d/init.d/autofs.RH62	Wed Feb  2 09:16:13 2000
+++ autofs	Thu Mar  2 14:29:58 2000
@@ -12,7 +12,7 @@

 # For Redhat-ish systems
 #
-# chkconfig: 345 15 85
+# chkconfig: 345 72 08
 # description: Automounts filesystems on demand

 # This is used in the Debian distribution to determine the proper
@@ -93,7 +93,7 @@
 	    fi
 	done
     )
-else
+fi

 #
 # Next check for YellowPage maps to be loaded
@@ -119,7 +119,6 @@
 	done
     )
   fi
-fi
 }

 #
Comment 1 Nalin Dahyabhai 2000-03-02 17:43:59 EST
This should already be fixed in Raw Hide, where autofs starts at step 18,
which puts it after 17 (ypbind).
Comment 2 Nalin Dahyabhai 2000-03-06 08:05:59 EST
*** Bug 9984 has been marked as a duplicate of this bug. ***
Comment 3 Nalin Dahyabhai 2000-03-06 08:06:59 EST
*** Bug 9983 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.