Bug 998426 - there are four "gluster" in qemu-img supported format list
there are four "gluster" in qemu-img supported format list
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Jeff Cody
Virtualization Bugs
:
Depends On:
Blocks: 1088695
  Show dependency treegraph
 
Reported: 2013-08-19 05:50 EDT by mazhang
Modified: 2016-09-20 00:39 EDT (History)
10 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.429.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1088695 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:50:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mazhang 2013-08-19 05:50:01 EDT
Description of problem:
there are four "gluster" in qemu-img supported format list, I don't know why has four in there, if it's expected, please close this bug.

Version-Release number of selected component (if applicable):
[root@m-qz ~]# rpm -qa |grep qemu
qemu-kvm-tools-0.12.1.2-2.389.el6.g13.x86_64
gpxe-roms-qemu-0.9.7-6.9.el6.noarch
qemu-kvm-0.12.1.2-2.389.el6.g13.x86_64
qemu-kvm-debuginfo-0.12.1.2-2.389.el6.g13.x86_64
qemu-img-0.12.1.2-2.389.el6.g13.x86_64


How reproducible:
100%

Steps to Reproduce:
1.execute "qemu-img" shows this help
#qemu-img
...
Supported formats: raw cow qcow vdi vmdk cloop dmg bochs vpc vvfat qcow2 qed vhdx parallels nbd blkdebug host_cdrom host_floppy host_device file gluster gluster gluster gluster

2.

Actual results:
there are four "gluster" in qemu-img supported format list

Expected results:
should be one in list

Additional info:
Comment 2 Asias He 2013-08-19 23:34:09 EDT
Please check the latest build.
Comment 3 mazhang 2013-08-19 23:38:28 EDT
qemu-img-0.12.1.2-2.397.el6.x86_64 also hit this issue.
Comment 4 Asias He 2013-08-20 03:42:47 EDT
We have the same issue with upstream qemu:
qemu-img version 1.5.91, Copyright (c) 2004-2008 Fabrice Bellard
Supported formats: blkdebug blkverify bochs cloop cow dmg gluster gluster gluster gluster iscsi nbd nbd nbd parallels qcow qcow2 qed host_cdrom host_floppy host_device file raw rbd sheepdog sheepdog sheepdog vdi vhdx vmdk vpc vvfat

The issue is we have:

static void bdrv_gluster_init(void)
{
    bdrv_register(&bdrv_gluster_rdma);
    bdrv_register(&bdrv_gluster_unix);
    bdrv_register(&bdrv_gluster_tcp);
    bdrv_register(&bdrv_gluster);
}

to register different gluster transport.

Each bdrv is printed in:
   
bdrv_iterate_format()


Also, please note, sheepdog block driver in upstream also has this problem.
Comment 6 Jeff Cody 2014-04-15 09:29:14 EDT
Some block drivers have multiple BlockDriver instances with identical format_name fields (e.g. gluster, nbd).  In those cases, the protocol_name is usually the more unique identifier (e.g. gluster+tcp).
    
Both qemu-img and qemu will use bdrv_iterate_format() to list the supported formats when a help option is invoked.  When just the format_name is used, redundant listings of formats occur (e.g., "Supported formats: ... gluster gluster gluster gluster ... ").
    
If we prefer the protocol_name over the format_name (when the protocol name exists), then that provides a more informative help message:
    
"Supported formats: ... gluster gluster+tcp gluster+unix gluster+rdma ... "


Patch submitted upstream.
Comment 8 Miroslav Rezanina 2014-07-04 03:09:49 EDT
Fix included in qemu-kvm-0.12.1.2-2.429.el6
Comment 10 Qunfang Zhang 2014-07-10 04:20:31 EDT
This bug could be reproduced on qemu-kvm-0.12.1.2-2.428.el6 and verified pass on qemu-kvm-0.12.1.2-2.430.el6.

Compared the "#qemu-img" output between the old and new version. 

[root@localhost ~]# diff old.txt new.txt 
1c1
< [root@localhost ~]# qemu-img
---
> [root@localhost ~]# qemu-img 
53,54c53
< Supported formats: raw cow qcow vdi vmdk cloop dmg bochs vpc vvfat qcow2 qed vhdx parallels nbd blkdebug host_cdrom host_floppy host_device file gluster gluster gluster gluster
< 
---
> Supported formats: raw cow qcow vdi vmdk cloop dmg bochs vpc vvfat qcow2 qed vhdx parallels nbd blkdebug host_cdrom host_floppy host_device file gluster


There's only 1 "gluster" in the qemu-img supported format list now. So the bug is fixed.
Comment 11 errata-xmlrpc 2014-10-14 02:50:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html

Note You need to log in before you can comment on or make changes to this bug.