Bug 998699 - command error in 5.8.6.2. Creating an SSL Certificate
command error in 5.8.6.2. Creating an SSL Certificate
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Alex Dellapenta
ecs-bugs
: Documentation
: 1020030 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 15:51 EDT by Doug Toppin
Modified: 2017-03-08 12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 16:33:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Toppin 2013-08-19 15:51:50 EDT
Description of problem:
The restart command at the end of section "5.8.6.2. Creating an SSL Certificate" should be 'service httpd restart' (currently says 'service restart httpd').

I also noticed that here and there the shell prompt is '$' (user shell) and most of the other places it is '#' (root shell).

Version-Release number of selected component (if applicable):
1.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Andrew Spurrier 2013-08-22 21:41:36 EDT
Section 6.8.6.1 Creating a Matching Certificate covers the same procedure a second time and gets the web server restart command correct.

I wonder if both sections are required and it looks a little disjointed reading them one after the other.

6.8.6.1 has a "Note" referring to the function "configure_wildcard_ssl_cert_on_node" in the kickstart script.  Unless I got the wrong kickstart script, that function does not exist.

I mention this as it is the 3rd way this document offers to achieve the same thing.
Comment 3 Miciah Dashiel Butler Masters 2013-08-22 21:47:35 EDT
The configure_wildcard_ssl_cert_on_node function is in the kickstart script to which the Deployment Guide links; see line 1719 in https://raw.github.com/openshift/openshift-extras/enterprise-1.2/enterprise/install-scripts/openshift.ks
Comment 4 Andrew Spurrier 2013-08-22 22:04:46 EDT
Excellent a much enhanced kickstart, at least longer!  
I had version 1.1 of the document and its associated kickstart.  
The URL to the kickstart file indicates the version bump.

The URL to either of the following failed to give me an indication of a version bump.  Also the "Cover Page" and "Page Header" just indicate version "1".

https://access.redhat.com/site/documentation/OpenShift_Enterprise/
https://access.redhat.com/site/documentation/en-US/OpenShift_Enterprise/1/pdf/Deployment_Guide/OpenShift_Enterprise-1-Deployment_Guide-en-US.pdf


Section 5.8.6.2 still has the "service restart httpd" bug instead of "service httpd restart".
Comment 7 Alex Dellapenta 2013-10-16 16:22:52 EDT
This has been fixed for the next release of the OpenShift Enterprise Deployment Guide.
Comment 8 Alex Dellapenta 2013-10-16 16:25:25 EDT
*** Bug 1020030 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.