Bug 998844 - Login to the remote window with -S/-s - option does not start a specific application instead of Explorer
Login to the remote window with -S/-s - option does not start a specific appl...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rdesktop (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ondrej Holy
Desktop QE
:
Depends On: 998843
Blocks: 998846 1068997
  Show dependency treegraph
 
Reported: 2013-08-20 04:06 EDT by Tomas Pelka
Modified: 2014-11-06 08:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 998843
: 998846 1068997 (view as bug list)
Environment:
Last Closed: 2014-11-06 08:26:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2013-08-20 04:06:25 EDT
+++ This bug was initially created as a clone of Bug #998843 +++

Description of problem:
Login to the remote window with -S/-s - option does not start a specific application instead of Explorer.

Version-Release number of selected component (if applicable):
rdesktop-1.6.0-8
rdesktop-1.6.0-7
rdesktop-1.7.1-1.el6
rdesktop-1.8.0-1.fc19.x86_64

How reproducible:
100% (Windows XP Professional, Windows 7, Windows 2008 Server)

Steps to Reproduce:
1. Type #rdesktop $WindowsIP -s "C:\Program Files\Internet Explorer\iexplore.exe" -S 18 (not depend on order of parameters)
2. Log into the remote system

Actual results :
Windows desktop is shown.

Expected results:
Internet Explorer is shown.

Additional info:
Comment 1 RHEL Product and Program Management 2013-10-13 22:39:30 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Ondrej Holy 2014-11-03 10:13:47 EST
It works correctly for me with RHEL 6.5 versions of rdesktop/xfreerdp and MSWS 2008, however the server should be properly configured. Terminal services role have to be added:
Server Manager -> Actions -> Add roles -> Server roles -> Terminal Services -> ...

Does it fix your problem?
Comment 6 Ondrej Holy 2014-11-04 04:23:54 EST
Also the program has to be added in the list of RemoteApps to avoid access denied error (TS RemoteApp Manager -> Add RemoteApp).
Comment 7 Vera Budikova 2014-11-04 10:07:26 EST
Yes, your steps were helpful. It works correctly for me with RHEL 6.6 and Windows 2008 Server. I think it is not a bug.
Comment 8 Vera Budikova 2014-11-06 08:26:05 EST
It works correctly for Windows XP SP3 -> close.

Note You need to log in before you can comment on or make changes to this bug.