This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 998849 - The status is unknown and the GUI is grey after the system has fully subscribed to the instance base subscription
The status is unknown and the GUI is grey after the system has fully subscrib...
Status: CLOSED DUPLICATE of bug 994992
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 04:25 EDT by Liushihui
Modified: 2013-08-20 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 11:38:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the rhsm log after run subscription-manger list --install (9.63 KB, text/x-log)
2013-08-20 05:30 EDT, Liushihui
shihliu: review+
Details

  None (edit)
Description Liushihui 2013-08-20 04:25:45 EDT
Description of problem:
After fully subscribe to the instance base subscription , the installed product status display "Unknown"

Version-Release number of selected component (if applicable):
subscription-manager-1.8.20-1.el5
virt-who-0.7-9.el5

How reproducible:
Always

Steps to Reproduce:
1. Registered to SAM server(10.66.12.119)
# subscription-manager register --username=admin --password=admin
2. Host subscribe to the instance base subscription(SKU:RH00003)
# subscription-manager subscribe --pool=8ac28da34095cf7a014095d3887400d9 --quantity=2
3. Check the consumed subscription 
# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Enterprise Linux Server, Premium
Provides:          Red Hat Enterprise Linux High Performance Networking (for RHEL Server) - Extended Update Support
                   Red Hat Enterprise Linux Server - Extended Update Support
                   Red Hat Enterprise Linux Server
                   Red Hat EUCJP Support (for RHEL Server) - Extended Update Support
                   Red Hat Enterprise Linux Resilient Storage (for RHEL Server) - Extended Update Support
                   Red Hat Software Collections (for RHEL Server)
                   Red Hat Beta
                   Red Hat Enterprise Linux High Availability (for RHEL Server) - Extended Update Support
                   Red Hat Enterprise Linux Scalable File System (for RHEL Server) - Extended Update Support
                   Red Hat Software Collections Beta (for RHEL Server)
                   Red Hat Enterprise Linux Load Balancer (for RHEL Server) - Extended Update Support
                   Red Hat S-JIS Support (for RHEL Server) - Extended Update Support
SKU:               RH00003
Contract:          10023540
Account:           5226325
Serial:            2678419616465863318
Pool ID:           8ac28da34095cf7a014095d3887400d9
Active:            True
Quantity Used:     2
Service Level:     Premium
Service Type:      L1-L3
Status Details:    
Starts:            07/12/2013
Ends:              07/11/2014

4. In the CLI, Check the installed products status 
# subscription-manager list --install
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        5.10 Beta
Arch:           x86_64
Status:         Unknown
Status Details: 
Starts:         07/12/2013
Ends:           07/11/2014

5.In the GUI, check "My installed products" tab, see the status of "Red Hat Enterprise Linux Server "


Actual results:
After step4, the status display "Unknown"
After step5, the status of "Red Hat Enterprise Linux Server " display "Unknown"

Expected results:
After step4, the status display "Subscribed"
After step5, the status of "Red Hat Enterprise Linux Server " display "Subscribed"


Additional info:
If it test against the stage candlepin ,it hasn't this problem.
Comment 1 Liushihui 2013-08-20 05:30:37 EDT
Created attachment 788398 [details]
the rhsm log after run subscription-manger list --install
Comment 2 Carter Kozak 2013-08-20 11:38:48 EDT

*** This bug has been marked as a duplicate of bug 994992 ***

Note You need to log in before you can comment on or make changes to this bug.